Start a new topic

Discover bank no longer offering QFX transactions downloads

I'm not clear on the difference between OFX and QFX, but it appears Discover Bank no longer supports either one - either for direct online import or file download for manual import.  This just happened in the last few weeks - I have been downloading/importing via QFX for years.


What are my options?  The idea of having to pay extra for MD+ to gain access to to transaction download functionality is really annoying.  If I were to go down that road, is Discover supported?


I called Discover, they gave me some gibberish about QFX (or OFX?) no longer being compatible with Quicken/QuickBooks.  Is this protocol going away?


Would love to know more about this - any info appreciated.


1 person has this question

Hi Karl,


Unfortunately we've heard this from other Discover customers too. We are encouraging everyone to complain to Discover, as they will be more responsive to many of their customers complaining, rather than a small company like us. There's really no reason for them to remove QFX downloads, as generating these files is pretty automatic and at no cost to them.


Discover provides CSV downloads on their website.  

CSV files can be imported into Moneydance, but unfortunately, the import process is a little more involved. CSV files were not designed to transfer data to personal finance programs, so there is no standard format or layout for these files.


You can import CSV files into Moneydance using File > Import.  

During the import process, you'll assign the columns in your CSV file to fields within the Moneydance account register. 


You'll find the steps for importing CSV files outlined in this article from the knowledge base.  


If you want to send us a copy or a sample of your Discover CSV file, you can create a private support ticket on this page. We can then let you know the exact settings you need to import the CSV file into Moneydance. Once we've determined which import settings you need, they should not change.



I just got off the phone with Discover's technical support to learn that this happened within the last week or so, and that it was a Quicken decision. Quicken is trying to push its users to use an Express Web Connect for their downloading of transactions. I am beyond annoyed at this point. Just sat down and was catching up on my finances to get this major roadblock. I use Discover as my primary card and have a lot of transactions to download. I will be reaching out with a private support tickets soon for money dance so I can get a workaround. UGH.

When importing the csv file from Discover the amounts end up in the wrong field (charges are shown as payments and vice-versa). Is there an easy way to fix this problem? The only fixes I can think of are to edit the csv file or to edit each transaction after importing.  

Hi Jan - what I ended up doing with the exported csv file, was adding a column next to the charges. I believe that column had the name "Amount". I just added another column next to it and also called it "Amount". I then made the equation for the new column to be  =-(A5). (A5 is my guess as to which column the original amount was in, "5"... but you get the idea). Also - it's hard to see here in my typing, but that is a negative sign just in front of the parenthesis, so therefore making the amount in the original column be "vice-versa". don't forget to save the new file with your new column in it.


Then when I went through the steps of importing this file into moneydance, a window pops up as I recall and walks you through a few steps - one of those steps is to choose which columns to ignore. So I ignored the first one named "amount"... this way only the new column I made got imported. This worked for me. I also took the advice of making a dummy test account to import it into just to make sure.... as the first time I did this and the numbers were all positive when should have been negative created a headached to go back and delete the wrong ones. 


I hope this makes sense. It's a real hassle to think that all these extra steps are now required.


Kristi

Thanks I will try that next month

Discover support told me the same thing.  However, so far this problem only exists  with Discover.  Mastercard and Visa cards import just fine this month. We will see what happens next month. :-)

Jan

When importing from .CSV you have to manually map the columns in the imported file to the fields in the record in MD.  You do that on this window (attached) during the import process.  In particular, 2 of the default settings should be checked - there are 2 dates in the .CSV file but only 1 in the MD record.  You need to select whether you want the 'transaction date' or the 'post date' entered in MD, and then set the other one to 'ignore'.  And for the amount, if you select debit amount rather than credit amount it will take care of the problem you reported with charges being shown as payments.

image


1 person likes this

 Thank you for your help Karl.

Login or Signup to post a comment