MD 2012 - Restoring a Checkpoint

First you need to locate your data set. By default, Moneydance 2012 and 2014 keeps your data set in an internal library. To access the default file location, navigate to Help --> Show Documents Folder.

Once you have located your .moneydance data file, Ctrl + click on the file name that matches the name at the top of your Moneydance window and select 'Show Package Contents'

If you're not using Mac OS X, you can simply navigate into your data set folder.

This will open up a folder that will show you current accounts file, the one ending with .mdinternal, and a folder called checkpt. Open the folder called checkpt.

The checkpt folder contains a collection of dated backup copies of your root.mdinternal file, which is your current data file.

checkptfolder_normal.png

At this point you will want to rename your main file to something like root.mdinternalOLD.
Any name change will do as long as it is meaningful to you.

After you have done this, you can simply re-open Moneydance.

If this file was opened previously, Moneydance will prompt you to restore a checkpoint and will present you with a list of checkpoints available, with their associated dates.

Alternatively, you can go to File -> Open to open the data set, then follow the prompts to restore a checkpoint.


If you'd prefer to restore the checkpoint manually, navigate to the checkpt folder within your .moneydance folder.

Then copy the root.mdinternal-YYYY-MM-DD file that you want to restore, to where the root.mdinternal file is currently stored (directly within the .moneydance folder).

At this point you will want to rename your main file to something like root.mdinternalOLD.
Any name change will do as long as it is meaningful to you.

Remove the date from the backup file so now it is just "root.mdinternal", replacing the other file we re-named.

Once you have done this, open Moneydance and navigate to File -> Open.

Open up the file with the name you are trying to restore.

In the above example this would be called "Demo".

You now have your backup file open, you can repeat this procedure for checking the others files.

Recent Discussions

19 Oct, 2017 01:30 AM
19 Oct, 2017 01:23 AM
18 Oct, 2017 11:56 PM
18 Oct, 2017 11:40 PM
18 Oct, 2017 10:23 PM