Moneydance 2017 - Backups, Exporting, and Data Locations

Manually exporting a backup -

Moneydance offers the ability to manually export a backup to a location of your choosing (external hard drive, thumb drive, etc). The exported file will have the file extension “.moneydancearchive” and is a compressed file.

For data fidelity reasons exported backup files do not contain data related to syncing with mobile devices (such as iPhones, Android devices, etc).

To export a backup go to File → Export Backup. Select the appropriate name and location for your backup file, and wait while Moneydance exports your data as a “.moneydancearchive” file. When the export is complete Moneydance will notify you that your data was exported successfully.

To open this “.moneydancearchive” file, go to File --> Restore from Backup. Navigate to and select the file, then click "OK".

Exporting data from Moneydance -

In order to export information from Moneydance go to File → Export.

  • Select your desired file format - you can export data from Moneydance in QIF, Tab-Delimited or Raw JSON format.
  • Choose a range of dates to be exported, or select "All dates" from the Date drop-down box.
  • Select or type the path of a destination file name (this file need not exist before you start the export).
  • Select the Currency to use for all financial values in the exported information.
  • Once you've set the parameters for the export, click "OK" and your file will be exported.

Default data locations -

Moneydance will store any new data files you create in the same, default location.

If you have not manually moved your data file to a different location, your files can be accessed by navigating within Moneydance to Help --> Show Documents Folder. The default location for your data file(s) varies depending on your operating system, and is listed below -

Mac OS X Lion, Mountain Lion, Mavericks, Yosemite, El Capitan and Sierra -

/Users//Library/Containers/com.infinitekind.MoneydanceOSX/Data/Documents

Mac OS X Snow Leopard -

/Users//Library/Application Support/Moneydance/Documents

More recent versions of Windows -

C:\Users<username>.moneydance\Documents

Older version of Windows -

C:\Documents and Settings<username>.moneydance\Documents

Linux -

/home//.moneydance/Documents

Moving your data -

If you already have your data in Moneydance but would like to store your data outside the Moneydance library, follow these instructions -

If you obtained Moneydance from the Mac Apple Store, unfortunately you cannot move your data file due to limitations imposed by Apple regarding the 'sandboxing' of Apps.

help_menu_2017.png

  1. While Moneydance 2015 is open, in the menu bar go to Help → Show Documents Folder. This will open a file browsing window. Close Moneydance, but keep this file browsing window open.
  2. You will see a folder in your file browser that looks like yourfilename.moneydance
  3. Move this folder to its new location. You only want one copy of this folder on your system, so it is important to move the file to the new location. If you copy the file, you'll have two seperate copies of your data set.
  4. Open Moneydance 2015, and in the "Welcome to Moneydance" window which appears click the "Open Other" button in the lower left hand corner.
  5. Navigate to the new location of your data file and click to open.

Moneydance will remember the new location of your file and open it automatically next time you launch Moneydance 2015.

show_documents_folder_2017.png

Renaming your data -

Once you have located your .moneydance file, you can rename the data set to the desired name.

Ensure that Moneydance is closed before making any changes to your file name. You must also ensure to retain the .moneydance extension when renaming.

When you then reopen Moneydance you will likely be presented with the 'Welcome to Moneydance' window.

If your newly renamed data set is not displayed on the right of this window, click the 'Open Other' option. A file browser will open, allowing you to navigate to and select your newly renamed data.

Deleting unwanted data -

To remove an unwanted, duplicate, old, or unused data set, open the data in Moneydance to ensure this is the correct file you'd like to remove.

If your data is stored in the default location, you can access it by navigating within Moneydance to Help --> Show Documents Folder.

After opening your data, if you're using a Mac, you can right click (or Ctrl + click) the Moneydance title bar, where the data set name is displayed. Then select the folder directly below your data set to open the folder that contains your data set in Finder.

MAC_title_bar_menu_2017.png

After doing that, a window will open and the data set to be removed will be selected (note: in some instances, the data set will have a folder icon instead of the Moneydance icon).

Switch back to the Moneydance window and close Moneydance before making any changes to the file.

Then right click the file and select to move the file to your recycle bin or trash folder (but don't empty it yet!).

After that, open Moneydance and you'll be brought to the Welcome screen, which will allow you to open your other data set(s).

Select your current data set and open it in Moneydance and make sure that your data is correct (this is to ensure that you removed the correct data set).

Once you've done that, you can safely empty your Trash folder! Repeat this process for any additional unwanted data sets.