Please Note: We've moved Moneydance and SyncSpace's support to a new location. Please join us for support and discussion at infinitekind.zendesk.com.

How to access internal backup files in Moneydance 2012

First you need to locate your data set. By default, Moneydance 2012 keeps your data set in an internal library.
To access this data go to Help->Show Documents Folder.

Help_menu.jpg

You may have also moved it to a different location or, upon upgrading from an earlier version, chose to have your data file not imported into the Moneydance documents library, so your data set may not be in that folder for those reasons.

Once you have located where your data set is, ctrl-click on the file name that matches the name at the top of your Moneydance window and select 'Show Package Contents'. If you're not using Mac OS X, you can simply navigate into your data set folder (which ends with .moneydance).

Screen_Shot_2012-09-20_at_8.02.35_AM.png

This will open up a folder that will show you current accounts file, the one ending with '.mdinternal', and a folder called checkpt. Open the folder called checkpt. The checkpt folder contains a collection of dated backup copies of your root.mdinternal file, which is your current data file.

checkptfolder_normal.png

At this point you will want to rename your main file to something like 'root.mdinternalrename'. Any name change will do as long as it is meaningful to you.

After you have done this, you can simply re-open Moneydance and, if you had the data set whose root.mdinternal file you just renamed opened previously, Moneydance will prompt you to restore a checkpoint and have a dated list of checkpoints available. Alternatively, you can go to File -> Open to open the data set and then be prompted to restore a checkpoint.

If you'd prefer to restore the checkpoint manually for any reason, navigate to the checkpt folder within your .moneydance folder, then simply copy the root.mdinternal-YYYY-MM-DD file that you want to restore to where the root.mdinternal file was that you renamed earlier (directly within the .moneydance folder) and remove the date from the backup file so now it is just "root.mdinternal".

Once you have done this, go to Moneydance and select menu: File -> Open and open up the file with the name you are trying to restore. In the above example this would be called "Demo". You now have your backup file open, you can repeat this procedure for checking the others.