Upgrading Moneydance 2015 (ver 1358) to MD 2019 (ver 1847) "Reminders-Overdue" Problem

vrden's Avatar

vrden

21 Jan, 2019 07:25 PM

Hi I've been using Moneydance since 2008. I've upgraded several times, including again today from version 1358 to version 1847. When I imported my Moneydance database using the tools provided with Moneydance (automatically launched upon initial start-up of the new release) all of my bank accounts balances are accurate (in the left panel (the one with Summary and Reminders at the top), however, the entries in the specific account registries are inaccurate, many entries are missing in my checking account for instance. I also noticed that there are about 60 Overdue transactions listed on the Summary page. It seems that the missing transactions are stuck in the Overdue Transactions list. These entries date back to May 2017. My view in MD 1358 does show three overdue transactions dating back to January 18, 2019.

UPDATE: OK, I'm looking through all of my accounts and it is obvious now that the import went very bad. There are multiple errors.
My question now is how do I delete the full database in MD ver 1847 and start over importing MD ver 1358 data. Is there anything I should know about the differences or incompatibilities between these two database versions?

Thanks,
Den.

  1. Support Staff 1 Posted by Ethan on 21 Jan, 2019 07:51 PM

    Ethan's Avatar

    I wonder if Moneydance somehow found an old backup file and imported that instead of your main data file. You shouldn't need to use the import functions to open an existing data file between versions.

    Do you know where your main data file is located? If not, it is likely in the default save location, which you can quickly reach by going to Help -> Show Documents Folder from the Moneydance menu bar. When you've located your data file, use the open other option from the Moneydance welcome screen or the menu bar (File -> Open -> Open Other) to select your yourfilename.moneydance data set.

    After that, we can work on removing any old or incorrect data files, like the one you just created.

    Ethan
    Infinite Kind Support

  2. 2 Posted by vrden on 21 Jan, 2019 08:07 PM

    vrden's Avatar

    Ethan, You are onto something here.
    1. When viewing MD ver 1358, Show Documents Folder indicates the .moneydance/Documents/den1.moneydance folder. However, in MD ver 1358 Window Titlebar "den1 - /home/dennisj/Downloads/tmp/den1" is displayed.
    2. I'm running MD ver 1358 on host1 and MD ver 1847 on a new, second host.
    3. What I did was I used rsync to move the .../Downloads/tmp/den1.moneydance folder over to the new host and put it in /tmp/den1.moneydance/
    So it looks like my problem is just as you explained.

    This time I used `scp -r` to copy ~/Downloads/tmp/den1.moneydance/ from the old host to the new host. I put that folder in ~/.moneydance/, fired up Moneydance (v1847) and everything looks good, just like it was under v1358.

    Thanks for your accurate assessment of my problem as well as the suggestion to solve it, job well done,
    Den

  3. Support Staff 3 Posted by Ethan on 21 Jan, 2019 08:25 PM

    Ethan's Avatar

    Hi Den,

    You wrote 1358 twice in your first point, so I can't quite tell which system had which. However, it sounds like you found your data file, called den1.moneydance.

    You should make sure this file is stored where you want to keep it on your new system. I mention this because if I'm understanding you correctly, it seems like you've placed it in a /tmp/ folder, which doesn't seem like a good place to store files you care about, at least with how most systems use that folder. Once you have placed that file where you want to keep it, use the open other option from the Moneydance welcome screen or the menu bar (File -> Open -> Open Other) to select your den1.moneydance data set in the location you've stored it. This should open your data. Does it appear to be correct?

    If so, you can remove other data files stored elsewhere that you may have created in the upgrade process. These are most likely in the documents folder on your newer system (Help -> Show Documents Folder from the Moneydance menu bar). You can delete these as you would any other file.

    Ethan
    Infinite Kind Support

  4. 4 Posted by vrden on 21 Jan, 2019 08:32 PM

    vrden's Avatar

    I was using ver 1358 on an old host running Fedora 25, The new host, running Fedora 29 has ver 1847 loaded on it.
    I had been storing the MD dataset in the Downloads/tmp folder temporarily back when I moved from MD 2011 to 2015, I guess I forgot that it was still there until today.
    You have helped me in several ways Ethan, Thanks a bunch.

    Den.

  5. Support Staff 5 Posted by Ethan on 21 Jan, 2019 08:39 PM

    Ethan's Avatar

    I'm glad we found your data file, and that nothing bad happened to it in that tmp folder these past few years!

    Please let me know if I can be of further assistance,

    Ethan
    Moneydance Support

  6. Ethan closed this discussion on 21 Jan, 2019 08:39 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac