CSV Import says dates are in error

smwhitehead's Avatar

smwhitehead

16 Sep, 2018 12:55 PM

I have recently switched to Moneydance and am trying to import Credit Card transactions. I am using the mdcsvimporter but I get an error on the date field and cannot see what I'm doing wrong. I have tried specifying various date formats and the result is always the same.

Here are some screen shots and the cut down CSV file. I have hopefully taken out any personal details.

Thanks for any help your able to give
Sue

This discussion was closed! See this FAQ for more information:

  1. Text File Importer Extension

    The CSV (comma separated values) format is essentially a table of rows and columns, like a spreadsheet. It is very versatile and not specifically designed to contain financial information.

    As such there is no standard way for a bank to store data in such a file. There is no standard order for the columns in a CSV file or names for those columns.

    As a result of this the import process for CSV files...

    See more..
  1. 1 Posted by Ian O on 16 Sep, 2018 12:59 PM

    Ian O's Avatar

    Hi Sue,

    You can find the steps to import a CSV file in this article. You shouldn't need to use the extension to import CSVs in the latest version of Moneydance but use the File --> Import action. Can you try this and let me know if you encounter any difficulties?

    Ian O
    Infinite Kind Support

  2. 2 Posted by -Kevin N. on 16 Sep, 2018 02:48 PM

    -Kevin N.'s Avatar

    Hi Sue,

    Thank you for the screenshots.

    I was able to successfully import your CSV file using the CSV Importer.

    Set up your Custom Reader per my screenshot. Pay careful attention to the Date format dd MMM yyyy.

    You didn't include any Payment transactions in your screenshot. However, your CSV file does seem to include a 4th column. I opted to designate that 4th column to Payment transactions. This is something that you may or may not need. I can't tell for certain without seeing how Payment transactions are constructed in your CSV file.

    HTH -Kevin N. (not a member of MD support)

  3. smwhitehead closed this discussion on 16 Sep, 2018 04:41 PM.

  4. smwhitehead re-opened this discussion on 16 Sep, 2018 04:42 PM

  5. 3 Posted by smwhitehead on 16 Sep, 2018 04:43 PM

    smwhitehead's Avatar

    Thanks for taking the time to reply. I was able to get it working by editing the CSV as Ian O's reply suggested. Kevin, when I tried your fix it still wouldnt parse the dates. Can't see any difference to what you did but at least I have a workaround now.

  6. 4 Posted by -Kevin N. on 16 Sep, 2018 05:01 PM

    -Kevin N.'s Avatar

    Hi Sue,

    The date format that worked for me was dd MMM yyyy - with a single space between the parameters.
    The one you used, per your screenshot was dd-MMM-yyy. The dashes are what is causing the parsing problem.

    I prefer the CSV Importer as I have several different credit cards that I need to create different custom readers for.

    I'm glad to hear that the built-in importer works for you. Be aware that (for me) the built-in importer does not remember it's prior settings but rather, reverts to it's default settings.

    -Kevin N. (not a member of MD support)

  7. 5 Posted by smwhitehead on 17 Sep, 2018 03:08 PM

    smwhitehead's Avatar

    Kevin, Thanks, I've got it working now. I think i had failed to save my changes when I edited the date format in the custom reader so it kept reverting to the old format.

    Thanks again. Sue

  8. smwhitehead closed this discussion on 17 Sep, 2018 03:08 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac