Latest release (2017.8) does not retain new history for security quotes

pfkalina's Avatar

pfkalina

09 Aug, 2018 06:46 PM

I noticed that 2017.8 (1691) will not retain the history for securities when MD is quit, then re-opened. I can get the quotes and exchange rates extension to work for small batches (4 or 5) of securities. The history then appears in security detail, as expected. When I quit MD, and immediately open it, the history reverts back to the prior state, and new data is lost.

I kept a copy of 2017.7.2(1672) and tried the same procedure with it. Now the history values are retained like they should be. It seems that this is a bug in the latest version.

  1. 1 Posted by mhoggie on 09 Aug, 2018 09:40 PM

    mhoggie's Avatar

    Running w7 64b MD build 1691

    Noticed the same issue with this release.

    Security history is not saved

  2. 2 Posted by pfkalina on 10 Aug, 2018 03:03 AM

    pfkalina's Avatar

    (Note: this comment was sent by mistake and does not apply to this issue. Please ignore.)

    I deleted the app, then reinstalled it. Now it is working again.

    Phil)

  3. 3 Posted by ralph on 10 Aug, 2018 06:37 AM

    ralph's Avatar

    I have the same problem and reinstalling didn't work for me

  4. 4 Posted by pfkalina on 10 Aug, 2018 01:34 PM

    pfkalina's Avatar

    Sorry, that comment about 'deleting the app' was sent by mistake and should not have been posted.

    Ralph, I did install the previous version of MD for the Mac (2017.7.2(1672)) and it appears to be working correctly, re saving new history. The most recent release does not.

  5. 5 Posted by mhoggie on 10 Aug, 2018 04:48 PM

    mhoggie's Avatar

    This is a strange problem. I'm running w764 with MD 1691 and played around with a couple of stocks, T and JCP.

    By selecting just those 2 quotes, I could get the Stock Quote extension to work without errors. Both would load about 3 months of stock price history. But both would loose all history data after I closed and restarted MD. The only exception was JCP where I had some old 2013 history that already existed for that security in MD. So the new quotes disappeared and the old ones were retained. That gave me an idea to try to manually enter stock prices for T. I messed around with a few where I just double clicked the entries in history and copied and pasted the info back to the entry. Then I closed MD and reopened. Those price entries still appeared but all others were gone. I did the same thing with JCP, but then it started to retain all the quotes, old and new. On the T stock, it only retained prices I manually re-entered. So I would guess the problem exists with the way the Stock Quote extension records the price quote in history, or possibly the way MD interfaces with that extension. I'm going to import some prices from a file and see if the same issue exists.

  6. 6 Posted by mhoggie on 10 Aug, 2018 06:27 PM

    mhoggie's Avatar

    Update, MD doesn't retain stock prices imported from a file. once you close MD, all quote history imported in previous session is gone. So it looks like MD needs to tweak the code to force the stock price changes to be written to disk when the application closes. Common problem with windows OS, because unlike Linux and other OS, windows does not write to the hard drive in real time. It can take minutes before memory is written to the hard drive. So the application has to force the write before it closes.

  7. Support Staff 7 Posted by Henry on 10 Aug, 2018 07:10 PM

    Henry's Avatar

    Hi All,

    Thank you for reporting the issue with 2017.8 (1691).
    I was able to reproduce the issue and have reported it to our developers.

    I will notify you as soon as possible.

    I apologize for the inconveniences caused.

    Henry
    Infinite Kind Support

  8. 8 Posted by ralph on 15 Aug, 2018 06:45 AM

    ralph's Avatar

    Hi Henry,

    An update on when this issue will be fixed would be appreciated

  9. 9 Posted by John Sawyers on 15 Aug, 2018 01:17 PM

    John Sawyers's Avatar

    I am having the same problem. Please notify me when the fix is available.

  10. Support Staff 10 Posted by Henry on 16 Aug, 2018 12:56 PM

    Henry's Avatar

    I'm very sorry to keep you waiting, the preview build 1693 is currently being uploaded and will be available on this page here:

    https://infinitekind.com/preview

    The preview will fix the historical rates saving issue in the entry cases listed below:
    - Automatic entry of security prices when recording transactions. - Entry of prices from imported QIF files. - When importing from past transactions. - When importing from imported CSV files

    Henry
    Infinite Kind Support

  11. 11 Posted by John Sawyers on 16 Aug, 2018 03:03 PM

    John Sawyers's Avatar

    I did as you instructed. It did not work. I updated all securities,
    closed MoneyDance and then reopened MD. All of the historical data was
    lost.

  12. 12 Posted by mhoggie on 16 Aug, 2018 03:39 PM

    mhoggie's Avatar

    Not MD support,
    While your waiting for 1693, there is a work around. After downloading your quotes, open the security history and select and delete the high quote. Then use your arrow key to move down and delete the next. repeat until you have touched all the quotes that were not stored on MD. Then run the quote extension to get the values again to restore the info you deleted. Now when you close and open MD, the values will still be there. All your doing is forcing MD to update the info in the account set . When they release 1693, all should be good.

  13. 13 Posted by -Kevin N. on 16 Aug, 2018 03:43 PM

    -Kevin N.'s Avatar

    Hi John Sawyers,

    Can you confirm that you are using build 1693?

    Per the Preview Build website, build 1693 hasn't posted yet. (11:40 AM EST)

    -Kevin N. (not a member of MD support

  14. 14 Posted by John Sawyers on 16 Aug, 2018 08:39 PM

    John Sawyers's Avatar

    Sorry--I didn't pay attention. It was 1691.

  15. 15 Posted by sth on 18 Aug, 2018 03:50 PM

    sth's Avatar

    And still no update???

  16. 16 Posted by Dan P on 18 Aug, 2018 04:12 PM

    Dan P's Avatar

    I'm also experiencing this problem (with prices imported by .csv).
    Still no preview uploaded?
    As a help, it would be nice to display the build in the file name.

  17. 17 Posted by sth on 18 Aug, 2018 09:42 PM

    sth's Avatar

    Which file? Not the executable please! I add version, build and date to the zip file and archive it. I think I have even more than the stable release page versions.....

  18. 18 Posted by Dan P on 18 Aug, 2018 09:54 PM

    Dan P's Avatar

    sth
    the filename of the installer.
    I went to the preview page on IK and downloaded the windows version. There is nothing I can see in file filename or on the web that tells me what version or build I'm downloading. I did this and installed it only to find it was build 1691, which I already had.
    What am I missing?

    ** Re-checking the preview page, I see a teeny tiny build to the right of the Mac software. Apparently that applies to all.

  19. 19 Posted by sth on 18 Aug, 2018 10:27 PM

    sth's Avatar

    Yeah, I see the issue, and yes the build number is next to the Mac version for some reason. Being a Mac guy I never looked further... :-)

    It is listed the same way on the preview and stable downloads page. I usually just check the changeling (dang autocorrect, changelog) page and it will note when a release is out and if it has any changes I care about.
    http://infinitekind.com/previewdl/current/changelog.txt

  20. Support Staff 20 Posted by Henry on 20 Aug, 2018 11:47 AM

    Henry's Avatar

    We had to make a change to the preview that was being uploaded which caused a delay in the upload.
    The preview 2017.9 (1693) is now available here:

    https://infinitekind.com/preview

    Henry
    Infinite Kind Support

  21. 21 Posted by John Sawyers on 20 Aug, 2018 12:11 PM

    John Sawyers's Avatar

    It didn't work for me. I downloaded and installed it. I confirmed that I was now running 1693. I updated 4 securities and checked to see that the historical prices were up-to-date. Then I closed MD and the reopened. The historical data for all 4 was lost--no change for me compared to 1691.

  22. 22 Posted by Dan P on 20 Aug, 2018 01:43 PM

    Dan P's Avatar

    Running Win 64bit, MD 2017.9 (1693)
    Imported 692 prices from csv file.
    Closed MD
    Re-opened MD
    All prices still there!

    Works for me!

  23. 23 Posted by mhoggie on 20 Aug, 2018 02:39 PM

    mhoggie's Avatar

    Mixed bag, on w7 64b build 1693

    Historical quotes are saved when importing from file, but are not saved when updating from Quotes and Exchange rate extension.

    Almost, but no cigar yet

    Mike

  24. 24 Posted by -Kevin N. on 20 Aug, 2018 02:52 PM

    -Kevin N.'s Avatar

    Hi Mike (mhoggie)

    Are you using V.1019 of the Q&ER updater?

    -Kevin N. (not a member of MD support)

  25. 25 Posted by mhoggie on 20 Aug, 2018 03:03 PM

    mhoggie's Avatar

    Nope, V.1018. Updated to V.1019 and all works good now. Thanks, Mike

  26. 26 Posted by Dan P on 20 Aug, 2018 03:09 PM

    Dan P's Avatar

    Mis read the previous post

  27. 27 Posted by derekkent23 on 20 Aug, 2018 03:25 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    I see preview build 1693 is now available, but have not run any tests.

  28. 28 Posted by John Sawyers on 20 Aug, 2018 07:35 PM

    John Sawyers's Avatar

    Just realized that not only do you need to update to 1693 but you also need to update "Quotes and Exchange Rates Updater" in Extensions. Now it works.

  29. 29 Posted by Pete Kockritz on 21 Aug, 2018 02:54 AM

    Pete Kockritz's Avatar

    1693 plus the extension update seems to have fixed it for my (Mac OS X 10.,12.6 ).

    The extension needs another change; it should throttle the quote downloads to AlphaVantage to perhaps use the batch API. You can only get 5 quotes at a time (in a one minute interval?).

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac