“fix_restored_accounts.py” did not solve problem

Elke Godfrey's Avatar

Elke Godfrey

09 Jun, 2018 11:47 PM

I have been using Moneydance for years without problems. Then suddenly there appeared out of nowhere in the column SECURITY CATEGORY, below almost every Security entry “Restored id=lc7bafb9-cb48-44de-0eac-337b74Expense”

From your support site I downloaded the file “fix_restored_accounts.py” and tried the procedure several times. It did not work for me.

First, on the Extension Menu, among the Manage Extensions options, I did not find the Python Interface extension. So, I went to your knowledge base and downloaded the Python Interface extension from there and tried to continue with your instructions.

When I was finally able to load the file “fix_restored_accounts.py” I kept getting error messages eg

There was an error running the script
/Users/elkegodfrey/Desktop/fix_restored_accounts.py.webloc
SyntaxError (no viable alternaqtive at character’?”. (‘/Users/elkegodfrey/Desktop/fix_restored_accounts.py.webloc’,
1,1,<?xml version=1.0”encoding=UTF-8”7>\n’))

error running script: SyntaxError: Non-ASCII character in file '/Users/elkegodfrey/Downloads/jpython.mxt', but no encoding declared; see http://www.python.org/peps/pep-0263.html for details

I am running macOS High Sierra Version 10.13.4

I have upgraded on your site to Moneydance 2017 (with the problem!!)

I would very much appreciate your assistance with this very vexing problem.

  1. 1 Posted by sth on 10 Jun, 2018 10:42 PM

    sth's Avatar

    In MD 2017 there is no longer a python scripting extension! Do not try to download and install such an extension. It won't work as you have found.

    In the menu Window->Python Scripting there is a python playground that will let you open a script and run it.

    I don't know if there is a special "fix_restored_accounts.py" for the 2017 version or not. There was a difference for the "remove one service.py" between 2015 and 2017 so there may be something similar. IK would need to chime in.

    You can try putting some prints in the "for loop" in the script to check progress of which accounts are being checked.

    Lastly, there should be no such text as "webloc" in your python script, that is a web reference and not a python script. Try re-downloading the script and check it in text edit to make sure it starts with:
    "from com.infinitekind.moneydance.model import *" just a user.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac