New Category issues

karenlowery5's Avatar

karenlowery5

14 May, 2018 04:06 PM

I made a new category last night and when I typed in an amount of $300.00, it added 30,000000.00. on the line below and a 0 in the preceding column. See attached file. I went back and looked at other categories and I did not see any check boxes that needed to be checked, or unchecked. Today, it did the same thing. I have used this program for a couple of years now and don't remember ever having this happen before. How, or what do I need to correct this annoying problem? Thanks.

  1. 1 Posted by -Kevin N. on 14 May, 2018 04:36 PM

    -Kevin N.'s Avatar

    Hi karenlowery5,

    Try this...

    From the Moneydance menu bar, go to Tools > Categories
    Locate and click on the INCOME-PHOTO RENTAL category. Click the 'Edit' button at the bottom of the window.

    In the resulting form, check to make sure that the 'Currency Type' is set to your base currency.

    -Kevin N. (not a member of MD support)

  2. 2 Posted by karenlowery5 on 14 May, 2018 04:51 PM

    karenlowery5's Avatar

    Hi Kevin. Yes, it is set to US Dollar.

  3. 3 Posted by -Kevin N. on 14 May, 2018 04:58 PM

    -Kevin N.'s Avatar

    Hi karenlowery5,

    Is the 'Parent' category 'CAPTURED MOMENTS' also set to 'US Dollar'?

    To resolve the issue with the original transaction, change the 0 to 1 and hit ENTER.

    -Kevin N. (not a member of MD support)

  4. 4 Posted by karenlowery5 on 14 May, 2018 05:09 PM

    karenlowery5's Avatar

    Yes Parent category is Captured Moments and it is set to US Dollar as well. It has worked fine for a couple of years. I did change the 0 to 1 and it went to $300. Will I need to continue to do this work around?

  5. 5 Posted by -Kevin N. on 14 May, 2018 07:07 PM

    -Kevin N.'s Avatar

    Hi karenlowery5,

    Will I need to continue to do this work around?

    I can't speak to that. I've not seen this behavior before.

    What version AND build number of Moneydance are you using?
    Menu bar > Help > About Moneydance
    I think for Macs, its Menu bar > File > About Moneydance

    -Kevin N. (not a member of MD support)

  6. 6 Posted by karenlowery5 on 14 May, 2018 07:09 PM

    karenlowery5's Avatar

    The version is: 2017.2 (1597)

    I will see if there is an update.

  7. 7 Posted by karenlowery5 on 14 May, 2018 07:11 PM

    karenlowery5's Avatar

    I don’t see a place to check for updates. Do not see under the normal Help, etc.

  8. 8 Posted by -Kevin N. on 14 May, 2018 09:17 PM

    -Kevin N.'s Avatar

    Hi karenlowery5,

    Yours is a slightly older build.

    MD 2017.7.1 (1671) is currently the latest build.

    Provided that you did NOT purchase Moneydance via the Apple store, then you can download the latest build here:
    http://infinitekind.com/download-moneydance-personal-finance-software

    -Kevin N. (not a member of MD support)

  9. 9 Posted by karenlowery5 on 14 May, 2018 09:41 PM

    karenlowery5's Avatar

    Thank you. I will download the lates build. I honestly don’t remember where I bought it. I kind of think just through the web site but will look into that. I do not remember any notices to update but could have slipped through the cracks. Thanks again for all your help. Truly appreciated.

  10. 10 Posted by -Kevin N. on 14 May, 2018 10:24 PM

    -Kevin N.'s Avatar

    Hi karenlowery5,

    You're welcome. I hope the new build resolves the anomaly.

    There was a Moneydance updater but it caused a few problems so I think that they mothballed it.

    To check for updates, I bookmarked the download page and just check it every now and then.

    -Kevin N. (not a member of MD support)

  11. 11 Posted by karenlowery5 on 14 May, 2018 11:44 PM

    karenlowery5's Avatar

    Thanks again. I did download and installed and did a test entry, but it did the same thing….I did go back and do another test entry on an older Category, and entered an amount and it worked just fine. It has something to do with the last two new Categories I made. Thanks for trying.

  12. 12 Posted by -Kevin N. on 15 May, 2018 01:38 AM

    -Kevin N.'s Avatar

    Hi karenlowery5,

    If there are not too many transactions involved, perhaps you should try deleting those transactions, delete the INCOME-PHOTO RENTAL category, restart Moneydance, then recreate the INCOME-PHOTO RENTAL category and try re-entering the transaction(s) again.

    I know... I'm grasping but there may have been some hiccup during the creation of the original category that is causing the issue.

    -Kevin N. (not a member of MD support)

  13. 13 Posted by karenlowery5 on 15 May, 2018 01:40 AM

    karenlowery5's Avatar

    Thanks for the idea. I will try that. I just created two new categories with one item in each, so will be easy to recreate. Will let you know. Thanks again.

  14. 14 Posted by karenlowery5 on 15 May, 2018 02:07 AM

    karenlowery5's Avatar

    Well, deleted categories and entries, closed Money Dance, restarted my computer, opened Money Dance, created both categories from the start (before trying to enter them) but…….it still didn’t work….Bummer…Thanks for tying.

  15. Support Staff 15 Posted by Ian O on 15 May, 2018 10:27 AM

    Ian O's Avatar

    Hi Karen,

    Sorry to hear of the strange behaviour you have encountered while using Moneydance. I'm wondering if you might have two 'US Dollar ' currencies in your data set. One set as the base currency, and the other assigned to some of your categories/accounts. If there is an exchange rate between the two currencies, this may explain the issue you are seeing. To check, can you navigate to Tools --> Currencies and have a look at the resulting list to see if two 'US Dollar ' currencies are listed. Please let me know what you find.

    Ian O
    Infinite Kind Support

  16. 16 Posted by karenlowery5 on 15 May, 2018 01:30 PM

    karenlowery5's Avatar

    Hi Ian. I checked the Currencies and yes, there are two US dollar currencies listed. I clicked on each one, and one seems to be grayed out and the other, seems to be accessible to click on it and then: “Set Base Currency”….. I presume I should delete one (?). If so, which one? I also had noticed this last night when pushing buttons and clicked on the little triangle downarrow in the “Payment Rate” column. It also showed two USD/USD. I am pretty sure I tried both of them.

    Thanks for continued support.

  17. Support Staff 17 Posted by Ian O on 15 May, 2018 02:10 PM

    Ian O's Avatar

    The currency that has the greyed out 'Set Base Currency' option is your current base currency. I believe the other is the duplicate currency that you'll be looking to remove.

    However, you'll be unable to remove this currency while it is in use and associated with any of your categories. You'll need to first alter the categories so they are using the correct USD currency. You'll be unable to alter the currency of the category while transactions are assigned to it.

    It might be easiest to remove the category in question and then recreate the category with the correct USD currency. Do you have many transactions assigned to this category? When you delete a category you will be required to reenter any transactions associated with the category.

    Ian O
    Infinite Kind Support

  18. 18 Posted by karenlowery5 on 15 May, 2018 04:02 PM

    karenlowery5's Avatar

    Ian. I went in and deleted the two new Categories. I then went in and deleted the two transactions. Then, I went to Tools>Currencies>went down to the two US Dollar listings. When I click on the top one it will not let me delete or anything as it appears to be greyed out. When I click on the 2nd US Dollar which does not appear to be greyed out, I then clicked on the Minus sign. It asks if I am sure I want to delete the currency US dollar? I say Yes and then it sys Cannot remove currency that is being used: US Dollar.

  19. System closed this discussion on 14 Aug, 2018 04:10 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac