"Duplicate transaction" does not work on first attempt

kongjie's Avatar

kongjie

20 Apr, 2018 06:21 PM

Problem: in a credit card account, I right-click a completed transaction and choose "duplicate transaction." The first time I try it, a new transaction is created with no details except for the default alphabetically first category. In other words, the same as if I had chosen "new transaction" from the "File" menu.

If I delete the blank transaction and reattempt the duplication, this time it works.

Running 10.13.4 with MD 2017.2 (1597)

  1. 1 Posted by -Kevin N. on 20 Apr, 2018 09:18 PM

    -Kevin N.'s Avatar

    Hi kongjie,

    Thank you for providing your Moneydance environment.

    You are using a slightly older build of MD 2017.

    Provided that you originally purchased Moneydance through the Moneydance website as opposed to the Apple Store, then you can download the latest build - currently MD 2017.7.1 (1671) here:
    http://infinitekind.com/download-moneydance-personal-finance-software

    Try updating your version and see if it helps with the issue.

    -Kevin N. (not a member of MD support)

  2. 2 Posted by kongjie on 20 Apr, 2018 09:25 PM

    kongjie's Avatar

    Kevin

    I updated to the latest build. Same results—new transaction instead of a duplicate.

  3. 3 Posted by -Kevin N. on 20 Apr, 2018 09:29 PM

    -Kevin N.'s Avatar

    Hi kongjie,

    Thank you for reporting back with your results.

    I can not reproduce this behavior with MD 2017.7.2 (1672) Preview Build in a Windows 10 Home 64-bit environment.

    I will yield to the support staff to help you further.

    I'm sorry that I couldn't be of more help.

    -Kevin N. (not a member of MD support)

  4. 4 Posted by sth on 21 Apr, 2018 03:48 PM

    sth's Avatar

    I can't reproduce this either Mac OS X. If I right click and select duplicate it creates a new transaction with the current details. (Mac OS X 10.11.6, MD 2017.7, build 1670)

    When you right click a transaction, that transaction highlights and shows that it is selected? Are you using a wireless or wired mouse, there used to be some issue with wireless Apple mice.

  5. 5 Posted by kongjie on 21 Apr, 2018 08:37 PM

    kongjie's Avatar

    I can reproduce this all day.
    1. Create a new transaction
    2. After being created, the transaction is highlighted.
    3. With the cursor over the highlighted transaction, press the control key and then click the mouse, then choose "duplicate transaction"
    4. A new transaction is created with no description, the default (alphabetically first) category, and no dollar amount.

    It does this with a Wacom tablet/mouse; it does this with a Logitech wireless mouse; it does this with no mice or peripherals and just the MacBook Pro's touchpad.

  6. 6 Posted by -Kevin N. on 21 Apr, 2018 09:17 PM

    -Kevin N.'s Avatar

    Hi kongjie,

    Following your steps, I am able to reproduce this behavior. I'd say that you've uncovered a legitimate bug.

    The workaround solution is to click away from the newly created (and highlighted) transaction, then go back to it and right-click it (CTRL-click for Mac) > Duplicate Transaction.

    -Kevin N. (not a member of MD support)

  7. 7 Posted by sth on 22 Apr, 2018 01:28 AM

    sth's Avatar

    I don't get step 2. When I create a New transaction by cmd-N, entering data and pressing enter the transaction is created but NOT highlighted. MD has started another new transaction at the bottom of the screen and I have to press ESC to close it.

  8. 8 Posted by -Kevin N. on 22 Apr, 2018 01:34 AM

    -Kevin N.'s Avatar

    Hi sth,

    pressing enter the transaction is created but NOT highlighted. MD has started another new transaction at the bottom of the screen...

    That's likely the option to 'Auto-create New Transactions' in Preferences.

    -Kevin N.

  9. Support Staff 9 Posted by Ian O on 22 Apr, 2018 09:51 AM

    Ian O's Avatar

    Hi All,

    Thanks for raising this behaviour, I've been able to reproduce the issue and will be raising this problem with our lead developer. I also had the 'Auto-create New Transactions' setting enabled but once this has been disabled kongjie's steps to reproduce does show the duplicate transaction function is not behaving correctly. As Kevin said, a legitimate bug.

    As a workaround, when the initial transaction is created and highlighted, click off the transaction before trying to duplicate should result in the transaction details being retained.

    Moneydance's lead developer Sean will likely be able to include a fix for this in the next preview build of Moneydance. I'll let you know of any developments. Please accept my apologies for the inconvenience.

    Ian O
    Infinite Kind Support

  10. 10 Posted by sth on 22 Apr, 2018 01:59 PM

    sth's Avatar

    Glad we got to the bottom of this. Kevin, very good catch on the preference!

  11. 11 Posted by kongjie on 22 Apr, 2018 07:04 PM

    kongjie's Avatar

    Great work figuring this out, thanks.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac