Perfectly valid lot matching rejected

wmchbaker's Avatar

wmchbaker

17 Mar, 2018 06:10 AM

Screen 1 (attached) shows sale on 10/22/15 properly matching a lot.

Screen 2 shows lot matching on 1/15/16 sale. Shares are allocated to lots, ready to hit OK.

Screen 3 shows incorrect allocation message.

When I hit OK I get shifted to securities detail screen. When I try to allocate shares there, I have the same results.

Am I doing something wrong or is file corrupted?

Thanks,
WB

  1. Support Staff 1 Posted by Henry on 20 Mar, 2018 12:40 PM

    Henry's Avatar

    Hi WB,

    Thank you for contacting us.
    Would it be possible for you to share your version and build number, to do this, open Moneydance and select Help --> About Moneydance (or Moneydance --> About Moneydance on a Mac) where the version and build number will be displayed?

    Also did you recently edit the security from avg cost (default) to lot match?

    Henry
    Infinite Kind Support

  2. 2 Posted by wmchbaker on 22 Mar, 2018 06:32 PM

    wmchbaker's Avatar

    Henry,

    Version/build is 2017.2 (1597)

    I have never switched this security from avg. to lot. It was imported from
    Quicken as lot costing and stayed that way.

    Thanks,
    WB

  3. Support Staff 3 Posted by Henry on 22 Mar, 2018 07:06 PM

    Henry's Avatar

    Would it be possible for you to upgrade to the latest preview of Moneydance from here:

    https://infinitekind.com/preview

    and see if that fixes the issue that you're seeing?

    Henry
    Infinite Kind Support

  4. 4 Posted by wmchbaker on 24 Mar, 2018 07:17 AM

    wmchbaker's Avatar

    Henry,

    Switching to latest beta is a disaster. When I went to the security screen
    for Amazon and clicked Edit Lots, I got a message that there were no stock
    sales to be matched. I thought the edit lots button would show me lot
    history. I added a sale in the register, tried Edit Lots and had the same
    result.

    I will go back to "official" version on the website, restore backup and
    hope I can get back to work.

    I am also unable to find this discussion in the MD help section.

    Screenshot attached.

    WB

  5. Support Staff 5 Posted by Henry on 25 Mar, 2018 03:48 PM

    Henry's Avatar

    Can you send me your errlog.txt file? If you're using Mac OS X, it should be located at one of these locations within your Home folder:

    ~/Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance/errlog.txt

    or:

    ~/Library/Application Support/Moneydance/errlog.txt

    If you have any trouble finding your Home Library folder, open Finder and select Go -> Go to Folder and and copy and paste in the following:

    ~/Library

    This should pull up your local Library folder.

    If you're using Windows, it should be located at:

    C:\Users\(yourusername)\.moneydance\errlog.txt

    I would like to send the report to our developers, to get more information on what can be done.

    Henry
    Infinite Kind Support

  6. 6 Posted by wmchbaker on 26 Mar, 2018 07:17 AM

    wmchbaker's Avatar

    Henry,

    You got it.

    WB

  7. Support Staff 7 Posted by Henry on 26 Mar, 2018 08:33 AM

    Henry's Avatar

    Thank you for the errlog.txt, it looks like there are a multiple invalid transactions in the logs.

    I've attached a file called "delete_invalid_txns.py" that should resolve this problem for you. Before proceeding, please back up your Moneydance data set, just in case something goes wrong. You can create a backup using the File --> Export Backup menu option.

    To use the .py file, first save it to your computer and then follow these steps:

    In Moneydance, select Window --> Python Scripting.
    In the window that opens, select 'Open Script' then navigate to the .py file wherever you saved it on your system.
    Select 'Run' to execute the file.
    Wait a few moments until you see a message on screen, confirming the script has run successfully.
    Once completed, restart Moneydance.

    Henry
    Infinite Kind Support

  8. 8 Posted by wmchbaker on 13 Jun, 2018 06:50 AM

    wmchbaker's Avatar

    Henry,

    Sorry for slow response, personal problems got in the way.

    I am going backward disastrously. I ran the provided .py file. The script
    interface screen said 0 transactions deleted. When I restarted MD and hit
    the Edit Lots button, I got the same message about no sales to match. I
    tried to restore the backup I had made several times. At first I
    accomplished nothing but getting MD to use 90% of CPU cycles for several
    minutes at a time and create new MD files that I couldn't load. Finally I
    succeeded in creating what looked like a successful restore. The banking
    register had up-to-date info but the edit lots screen had the same message
    about no sales to match. I tried a number of securities, including
    securities imported from Quicken. All reported no sales to match and none
    showed me existing lots.

    Then the really scary part is I restored a backup I had made a few days ago
    before messing with the py file, and had the same results, except the
    banking transactions entered in the last few days are not in the register,
    which obviously makes sense. Unless you can work some magic with the
    errorlog (attached), it appears all lot info is lost.

    William

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • lots_screen_1.jpg 169 KB
  • lots_screen_2.jpg 176 KB
  • lots_screen_3.jpg 170 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac