Cannot upgrade MD 2017.2 (1597) to 2017.3 on Fedora 27

Kimberly's Avatar

Kimberly

08 Mar, 2018 11:41 PM

Hi,

I have owned and used MoneyDance 2017 for roughly a year, and an extension to check for updates tells me that I should be able to upgrade from my current build (2017.2 build 1597) to MoneyDance 2017.3. I enter my Activation code into the website, but the version that downloads is 2017.1. I am using Gnome Packages but I do not see MoneyDance as an installed program, even though it is installed. When I try to install the "update", it tells me the program is already installed. I welcome any suggestions you have to offer to help me upgrade. I miss my stock quote updater.

Thank you.

  1. 1 Posted by derekkent23 on 09 Mar, 2018 09:06 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    The Moneydance Updater extension is not working. If I was you I would uninstall it until it gets fixed. Current release build is 2017.6(1656).

    Maybe you are not aware that now both Yahoo and Google have shut down their free API quote and exchange rate service which Moneydance used, Moneydance has added another free service from Alpha Vantage. To use this service you have to be running the latest build of 2017, if you purchased direct then download from https://infinitekind.com/download-moneydance-personal-finance-software

    Once installed click on EXTENSIONS – MANAGE EXTENSION and update the extensions to give a Quote and Exchange Rate extension to v1015. When you start the extension, you will be given a link to obtain an Alpha Vantage key. Once obtained enter the key into the box provided an in the dropdowns set them to Alpha Vantage.
    If for any reason Alpha Vantage does not return quotes on all your securities there is a free alternative.

    I am using a stand-alone program that was originally developed to help out users of MS Money when Microsoft stopped supporting that product. The program is in java, like Moneydance and thus runs on Windows, Mac and Linux computers. The developer has adapted it to work with Moneydance and is actively supporting the program. This program is very stable and the quotes very consistent with the option of two sources, not Alpha Vantage. No strange prices. It has a lot of useful features. These include, obtaining prices from many stocks and fund quoted on different exchanges, US, Canada, UK, Europe and Australia. I am a UK investor and have found that Alpha Vantage provide very poor support for UK/Irish/Luxenberg etc, domiciled funds. Alpha Vantage sometimes switches back and forward between Pence and Pounds. No such problem with the stand-alone program. The program has the ability to convert quotes from one currency to another. Convert prices in Pence to Pounds, if required, for UK stocks and funds. More features in the pipeline. Provide a means for importing all this data into Moneydance. You can also import exchange rates along with your security prices, if required.
    Take a look at his thread and download the PDF outlining how to use the program and link to download the program.
    http://help.infinitekind.com/discussions/investments/3036-third-par...

    Hope this helps.

  2. 2 Posted by Kimberly on 10 Mar, 2018 12:05 AM

    Kimberly's Avatar

    Thank you for your response and the suggestion for the third party stock quote updater. I will look into that after I am able to update Moneydance.

    I have downloaded the 64-bit RPM file (for Fedora 27) directly from InfiniteKind's website. After it finished, I opened up my downloads folder and double-clicked on the .rpm file. The version still reads 2017.1 and I see an option to install the program. After clicking the install button, it asks me for my password. The progress bar jumps up to 79% then disappears, and the program does not update or install. The "install" button is still active. Underneath "Details" it reads:

    Version 2017.1
    Updated Never
    License Unknown
    Source moneydance_linux_amd64.rpm
    Download Size 0 bytes

    I never get any further than that and I cannot upgrade to 2017.6(1656). I have tried this multiple times with the same result. I would try uninstalling the program, but it does not register as an installed package, so I am unsure how to do that. Any suggestions are appreciated.

  3. 3 Posted by derekkent23 on 10 Mar, 2018 09:25 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    Look like you need help from another Linux user or support.

    SUPPORT PLEASE STEP IN

  4. Support Staff 4 Posted by Henry on 21 Mar, 2018 04:21 PM

    Henry's Avatar

    Hi Kimberly,

    Please accept my sincere apologies for the delay getting back to you. I’m afraid that your request for assistance was missed by the support team, and it’s only now we’ve been able to work through the backlog of older discussions.

    I believe we have had a report on an issue where the version appears to be the same and after the install was completed the correct version was installed.

    Would it be possible for you to install the rpm file through the terminal?
    To do this open a terminal and navigate to the folder where the rpm file is, if it's in the downloads folder then type in

    $ cd ~/Downloads

    tap Enter

    then type in

    $ sudo dnf install moneydance_linux_amd64.rpm

    Please let me know how it goes.

    Henry
    Infinite Kind Support

  5. 5 Posted by Kimberly on 23 Mar, 2018 12:09 AM

    Kimberly's Avatar

    Hi Henry,

    I have tried that before and it didn't work. I just tried again and got the same result. See below:

    [jHFksdf@localhost Downloads] $ sudo dnf install moneydance_linux_amd64.rpm Last metadata expiration check: 1:05:27 ago on Thu 22 Mar 2018 06:54:44 PM EDT.
    Error: Will not install a source rpm package (Moneydance-2017-1.src).
    [jHFksdf@localhost Downloads] $

    It won't install that way either. I welcome any other suggestions you may have.

  6. Support Staff 6 Posted by Henry on 23 Mar, 2018 02:33 PM

    Henry's Avatar

    Thank you for your reply, would it be possible for you to use the tar.gz packages which are basically just a folder that you can un-pack on your machine and run it from anywhere.

    Our lead developer confirmed that we will switch our installer software to reduce the issues with the generated RPM files when using modern package management software.

    Henry
    Infinite Kind Support

  7. 7 Posted by Kimberly on 24 Mar, 2018 04:33 PM

    Kimberly's Avatar

    Hi Henry,

    I downloaded the .tar.gz file and extracted it to /Home/MoneyDanceGZ/. I see a bunch of files that I do not know what to do with. If you could provide me with step by step instructions, I would be most grateful. Thank you.

  8. Support Staff 8 Posted by Henry on 25 Mar, 2018 04:58 PM

    Henry's Avatar

    Perfect! Do you see a "Moneydance" folder after you have extracted the file?
    Inside that moneydance folder is a file called "Moneydance". Double clicking on that file will run the program.

    Henry
    Infinite Kind Support

  9. 9 Posted by Kimberly on 27 Mar, 2018 11:24 PM

    Kimberly's Avatar

    Hi Henry,

    Thanks so much for your help. I was able to get the new version of Moneydance to run, but only after opening a terminal window and manually launching the program using the sh command. Apparently my default program to open this file is set to a text editor. I am not sure how to fix this or what the app is I need to associate this program with in order for it to launch with a double click. Right now it just opens up the shell script in my text editor when I do that.

    Any advice you have is greatly appreciated. I'd like to be able to link it so that it launches from the Activities bar. Thank you again!

    Kimberly

  10. 10 Posted by cm on 27 Mar, 2018 11:57 PM

    cm's Avatar

    Hi Kimberly,

    I also use Fedora 27. As you've now figured out, they did not set the version in the rpm correctly, and all 2017.* version look like 2017.1 to Fedora. The simple solution to your problem is to uninstall MoneyDance then install from the latest downloaded file, like so:

    dnf remove Moneydance-2017-1.i386

    dnf install moneydance_linux_amd64.rpm

    Your settings and data are not affected.

    I'm surprised the support team hasn't suggested this!

    Now the latest 2017.7 is not installing for me -- separate issue I've a ticket open -- but the above has worked for me since 2017.2. Hope this helps!

  11. 11 Posted by S on 08 Apr, 2018 12:44 AM

    S's Avatar

    Hi,

    I have Fedora 27 and have the same error.

    #sudo dnf install moneydance_linux_amd64.rpm

    Last metadata expiration check: 1:37:01 ago on Sat 07 Apr 2018 07:03:02 PM EDT.
    Error: Will not install a source rpm package (Moneydance-2017-1.src)

    I was able to download the latest source package, Moneydance_linux_amd64.tar.gz, and run from a terminal window. The reported version is 2017.7.2(1672).

    Is the older version a workaround until 2017.7 is fixed?

  12. 12 Posted by cm on 08 Apr, 2018 03:18 PM

    cm's Avatar

    Hi S,

    After uninstalling any older version of MD, you've to download the latest binary rpm package -- mine was v2017.7.1 (build 1671) -- and install with rpm instead of dnf:

    #rpm -ivh /yourPathTo/moneydance_linux_amd64.rpm

    That works for me, but using dnf to install it still gives me the same error. Didn't know there's a build 1672...

  13. 13 Posted by Jim on 12 Apr, 2018 02:18 PM

    Jim's Avatar

    IK Support,

    Here is the easy way to find the root cause and solve this problem: What changed in your build pipeline for RPMs between 2017.6 and 2017.7.1 (1671)?

    It's pretty clear from the fact that this wasn't an issue with any prior version that something has changed. This line right here is the problem: Error: Will not install a source rpm package (Moneydance-2017-1.src)

    Forcing an install with rpm is a work-around, not a solution. RPM packages are not my area of expertise, otherwise I'd dig into the current and previous version packages to look for clues. I'd guess there was a change to the spec file, but no idea what/where. Hopefully you've got all this stuff tracked in a VCS.

    And since I'm finally in here making requests, please update the package version when building your RPMs so we can just update the package instead of having to run dnf reinstall, use rpm, or remove and then install. And the architecture for the x64 rpm incorrectly states "i386".

    For the record, I took the time to make a post with concrete suggestions because I like MD and want to make it better. I'm not just here to complain. Fixing the last two problems I mentioned will make it easier for you guys to troubleshoot issues down the road too. This way users can give you accurate version information by running an rpm -qi query (particularly useful if the program doesn't start for some reason and the user doesn't know the version).

  14. 14 Posted by Ryan Hoagland on 24 May, 2018 02:23 AM

    Ryan Hoagland's Avatar

    I'm currently testing Fedora 28 in a virtual environment and can confirm this issue.

    @Jim: Excellent and concise suggestions, I hope the development team will follow through.

  15. System closed this discussion on 23 Aug, 2018 02:30 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac