Upgraded but can't find the files from the 2012 version to move to new version

Thomas's Avatar

Thomas

18 Jan, 2018 02:21 AM

Hi,

I've been using Version 2012 (825) of Moneydance and decided to upgrade today to the latest version. I'm running Mac OSX High Sierra, 10.13.1.

I can't figure out how to load the data from the 2012 version into the new version. I'm not even sure what I should be looking for when I click on "import." Or should I even be clicking on "import"? I'm pretty lost...

Thanks,

TO

  1. Support Staff 1 Posted by Ethan on 18 Jan, 2018 02:24 AM

    Ethan's Avatar

    Hello,

    Do you remember where you were saving your data in the 2012 version? It should be in a file called something like yourfilename.moneydance. If you know where you were saving your data, use the open other option from the Moneydance welcome screen or the menu bar (File -> Open -> Open Other) to select your yourfilename.moneydance data set. The program will then convert your data into the 2017 file format, and display it on the screen.

    If you're not sure where you were saving your data, it is likely in the default save location, described at http://help.infinitekind.com/kb/file-locations-and-changes/default-...

    Ethan
    Infinite Kind Support

  2. 2 Posted by greenprius on 19 Jan, 2018 12:56 AM

    greenprius's Avatar

    Thanks for the quick reply, Ethan.
    I'm not finding my old data, but it's all there when I open the 2012 version. Can i somehow save it from the 2012 version to a file/location/format that I could then access and open with the new Moneydance?

    Thanks,
    TO
        On Wednesday, January 17, 2018, 8:24:26 PM CST, Ethan <[email blocked]> wrote:

    |

  3. 3 Posted by sth on 20 Jan, 2018 02:07 AM

    sth's Avatar

    In the 2012 version go to Help->Show Documents Folder and it should open the folder where the data files are stored by default.

  4. Support Staff 4 Posted by Ethan on 20 Jan, 2018 05:45 PM

    Ethan's Avatar

    I believe on most versions of Moneydance on Macs one can also right-click on the middle of the title bar where it displays the file name to reveal the folder path to the file you have open.

    Ethan
    Infinite Kind Support

  5. 5 Posted by greenprius on 21 Jan, 2018 08:09 PM

    greenprius's Avatar

    Thanks Ethan, and the unknown earlier person who chimed in. I'm attaching a screenshot of the window that opens when I go to Help>Show Documents Folder (Moneydance file location 1). The file that I had been using for the 2012 version is moneydance.moneydance, but I also had created moneydance backup011718.moneydance when trying to find a way to get this data into the new version. It's  not easy to find, but I opened Moneydance 2017 and navigated to (I think) this folder using the File>Open>Open Other command. I'm attaching a screenshot of the window that I navigated to when I used this command (Moneydance file location 2). However, when I click on moneydance.moneydance in this folder and click open, the program works for awhile but fails to load anything. The title bar, however, says moneydance - moneydance. I notice that moneydance.moneydance is actually a folder. I'm attaching a screenshot of what's in that folder (Moneydance file location 3). Should I be opening a folder or file from within moneydance.moneydance?
    Sorry to be so dense.
    Thanks,
    TO
     

        On Saturday, January 20, 2018, 11:45:49 AM CST, Ethan <[email blocked]> wrote:
     
      
    |

  6. 6 Posted by sth on 24 Jan, 2018 02:59 AM

    sth's Avatar

    Just a suggestion but you should probably have a better name than Moneydance for you financial data.....

    The 2012 MD files had an extension .md and you should look for those and/or any backups to do the update over. I think Moneydance does not delete those files on upgrade but hides them somewhere. Try searching your home directory for .md as a file name.

    Once you have the 2012 original file (make a backup on external or flash key). Then try updating one version at a time using the trial versions for previous versions of MD. Finally ending with MD 2017.

  7. 7 Posted by greenprius on 03 Feb, 2018 08:22 PM

    greenprius's Avatar

    Still couldn't find files that would load onto the new program, so I went to the old Moneydance program and exported the records as a moneydance 2010 format file. Then I imported it into MD 2017. That seems to have worked. Keeping the old version around for awhile until I'm sure this one is working... I have backup in the cloud and backup onto a flash drive.
     

        On Tuesday, January 23, 2018, 8:59:59 PM CST, sth <[email blocked]> wrote:
     
       
    |

  8. Support Staff 8 Posted by Ethan on 03 Feb, 2018 08:36 PM

    Ethan's Avatar

    That's strange that the files could not be located, but I'm glad you found a method that worked for you. I don't think you should experience any data loss by exporting back from the 2012 to 2010 version, but you may want to look at things like Reminders and your bank connections, if you have those set up, as those may have been affected by this method.

    Ethan
    Infinite Kind Support

  9. System closed this discussion on 05 May, 2018 08:40 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac