Security and currency prices won't up date

John Bishop's Avatar

John Bishop

02 Nov, 2017 09:53 AM

This morning for, for the first time, my file will not up dat with security and currency prices from Yahoo USA

Showing page 6 out of 6. View the first page

  1. 151 Posted by -Kevin N. on 06 Dec, 2017 09:26 PM

    -Kevin N.'s Avatar

    Hi emiddleton,

    Can you confirm that the current price (if manually entered) is not supposed to change until a download the next day?

    For me, in testing a QIF import, the 'Current Price' field (if entered manually) would not change with subsequent imports, for the current day.

    I can not however confirm that, that behavior is the intended behavior when using the Q&ER updater; I'm not using it.

    For me, v1008 / Alphavantage is too slow and settlement for mutual funds was too late in the evening. Hence, importing a QIF file of quotes is my method of choice.

    -Kevin N.

  2. 152 Posted by -Kevin N. on 06 Dec, 2017 09:29 PM

    -Kevin N.'s Avatar

    Hi Des,

    I always appreciate your insights into various matters. They're always well thought out and hard to argue with. :)

    -Kevin N.

  3. 153 Posted by dwg on 06 Dec, 2017 09:55 PM

    dwg's Avatar

    Hi Kevin,

    Having both being a customer of many companies in the computer industry and also having worked for hardware/software manufacturers/vendors I suppose allows me to see problems from both sides, it can be an interesting tightrope walk when you are in the middle.

    Still it doesn't stop me speaking out when I'm not impressed, probably to the ire of many :) Doubt if I'm on TIK's favourites list at the moment.

    Des

    Des

  4. 154 Posted by yardy on 07 Dec, 2017 05:02 PM

    yardy's Avatar

    Hi, I loaded 2017.6 (1653) and also the new extension for Quotes & Exchange Rates, I also got an API. However when I run the extension it says it downloaded 17 quotes (correct) with 17 errors - no data found. Also less than 50% of the exchange rates reported being downloaded. Finally when I close MD and re-open it I have to re-enter Alphavatage and change the next download date as it reverted to 11/22/2017 and also re-enter the API. So I believe I did everything correctly but it does not work. I also tried using the 'Test' function in the extension and was told it was 'downloading'. After all this nothing was added to the history of the stock prices and the current price was not changed. Any suggestions ?

  5. 155 Posted by jonthaler on 08 Dec, 2017 05:21 AM

    jonthaler's Avatar

    @yardy: II see similar behavior, but it varies. Sometimes I get no new data, sometimes I get everything I want (ie, al requested security prices), and sometimes other combinations. For example, this evening (11 PM CST) I got all the stock prices but no mutual funds. This is clearly still a beta version of the new SW.

    I see that there is a new build. I'll install it and see what happens.

  6. 156 Posted by sth on 08 Dec, 2017 05:18 PM

    sth's Avatar

    @yardy, you will not see the "next download date" change unless you wait until that date and then download. It will then update to the following day. You should not bother changing it. If you force two downloads in the same day that is fine with the Update button.

    If you look in the console log, you should see the exact URL used to retrieve your data. If you are getting no data, then it is because either the API key was entered wrong, or those securities are not supported by AlphaVantage.

    @jonthaler, mutual funds do not update until late, sometimes 10 or 11 PM EST. It may have been been a later date. AlphaVantage doesn't update the mutual fund prices all that early. This won't change with a new build.

  7. 157 Posted by HELEN on 13 Dec, 2017 03:08 AM

    HELEN 's Avatar

    i ADDED the api key as explained, but when i went to test it , i received this
    history x "sun.security.validator. VALIDATOREXCEPTION: no
    trusted certificate found." - and nothing downloaded . i am trying to download from the toronto stock exchange, any thoughts on this? thx

  8. 158 Posted by sth on 13 Dec, 2017 04:39 AM

    sth's Avatar

    @helen, yes. To get the latest certificates for secure communication you need to install the latest (or a very recent) build from the preview site. You must be running MD 2017.6 and will have to update if you are running an older version.

  9. 159 Posted by john bishop on 21 Dec, 2017 09:03 AM

    john bishop's Avatar

    I started the discussion at outset. I have been using the new download function with very mixed results. The "test" function doesn't work at all. On one occasion I got a completely accurate set of values, on download but most of the time I get nonsense answers for two or three different securities - but not always the same ones

  10. 160 Posted by sth on 22 Dec, 2017 03:01 AM

    sth's Avatar

    John, what currencies are you using. There seems to be some weirdness when trying to update securities in currencies other than the file base currency.

  11. 161 Posted by emiddleton on 22 Dec, 2017 03:44 AM

    emiddleton's Avatar
  12. 162 Posted by derekkent23 on 01 Jan, 2018 11:47 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    For anyone who is interested take a look at this thread on a third-party Quote and Exchange Rate Program from hleofxquotes.
    http://help.infinitekind.com/discussions/investments/3036-third-par...

    Hope this helps.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac