Bottom half of text cut off in Red Hat Linux distros (RHEL, CentOS 7, Fedora, etc.)

Jim's Avatar

Jim

14 Oct, 2017 06:48 PM

When opening Moneydance the "Please Enter Your Password" window has some text that doesn't display correctly. Specifically the line that states "Enter the password to decrypt this file" has the bottom half of the text cut off. I've attached a screen shot which shows this problem.

The problem started after my upgrade from CentOS 7.3 to 7.4.
I currently run MD 2017.6 (1644) on CentOS (Red Hat) Linux 7.4.
The same problem occurred with Moneydance 2017.4 (1624) on CentOS 7.4.

I just realized this same problem affects several other areas like some of the preferences text and the "Expenses Graph" on the summary page. Screen shots attached in the post below.

  1. 1 Posted by Jim on 21 Oct, 2017 06:31 PM

    Jim's Avatar

    I just realized this same problem affects several other areas like some of the preferences text and the "Expenses Graph" on the summary page. Screen shots attached.

  2. 2 Posted by Jim on 05 Jan, 2018 04:26 AM

    Jim's Avatar

    Still an issue with 2017.7 (1659) on CentOS 7.4.

  3. 3 Posted by Scott M. on 05 Jan, 2018 05:13 AM

    Scott M.'s Avatar

    I had this same issue with Ubuntu Gnome 17.04, but it went away with 17.10.
    Are you using the Gnome Desktop?

  4. 4 Posted by Jim on 05 Jan, 2018 06:22 PM

    Jim's Avatar

    I'm running CentOS 7.4 which uses Gnome 3.22. It looks like Ubuntu GNOME 17.04 is based on GNOME 3.24 and 17.10 is based on GNOME 3.26. I doubt CentOS 7 will update its Gnome version again, so maybe I'll have to wait for CentOS 8 to get this fixed. Thanks for giving me hope that this might get fixed by a Gnome update someday.

  5. 5 Posted by Scott M. on 05 Jan, 2018 07:07 PM

    Scott M.'s Avatar

    I tried it in a VM of OpenSuse Tumbleweed at the time and had the same issue. You can drag the bottom of that password window and open it wider and it goes away, but it doesn't stick.
    My error log said this:
    error loading properties for theme custom from URL: file:/home/"myusername"/.moneydance/custom_theme.properties error: java.io.FileNotFoundException: /home/"myusername"/.moneydance/custom_theme.properties (No such file or directory) initialised mono font: java.awt.Font[family=Dialog,name=Gill Sans,style=plain,size=12

    But I wasn't using a custom theme, so I don't know. But the Gnome update fixed it. I thought it might be a font related issue.
    Have you tried changing the theme on the OS itself? Try Arc or Radiance and see if it makes a difference. That's the one thing I didn't do.

  6. 6 Posted by dwg on 05 Jan, 2018 08:15 PM

    dwg's Avatar

    The so called error on loading custom themes is a misleading message in his case.

    All it really means is that you are not using a custom theme, you are just using a standard theme, that is all.

  7. 7 Posted by Jim on 06 Jan, 2018 12:22 AM

    Jim's Avatar

    I tried Arc, Radiance and a few other themes. I also tried changing my font settings, nothing helped. Thanks for the ideas though.

  8. System closed this discussion on 07 Apr, 2018 12:30 AM.

  9. Jim re-opened this discussion on 12 May, 2018 07:50 PM

  10. 8 Posted by Jim on 12 May, 2018 07:52 PM

    Jim's Avatar

    Unfortunately this is still occurring with CentOS 7.5 which has Gnome 3.26. I'm currently using Moneydance 2017.7.2 (1672).

  11. 9 Posted by info on 13 May, 2018 11:11 AM

    info's Avatar

    I have the same problem on Fedora created a duplicate issue with support - no response.. Another bad issue is the pop calendar -- because the alignment is so off, you can not even use the mouse...
    Fedora release 28 (Twenty Eight) and MD 1672

  12. 10 Posted by Jim on 27 May, 2018 01:42 PM

    Jim's Avatar

    Info, I hadn't noticed the popup calendar issue before, but now that you point it out I also have that same problem. In my case, however, the calendar is still usable, I just have to click on the top half of the number (date). It is another annoyance to using MD on CentOS though.

    Do you have a link to your issue? Did you get a response from support?

    Based on http://help.infinitekind.com/discussions/problems/28640-fedora-25-small-problems it looks like overriding the Java version may help, but I'm not sure which file they edited.

  13. 11 Posted by info on 28 May, 2018 10:08 AM

    info's Avatar

    Nothing from support... I will look info the java version. Thanks.

  14. Support Staff 12 Posted by Ian O on 28 May, 2018 10:21 AM

    Ian O's Avatar

    Hi All,

    Please accept my sincere apologies for the lack of response on this thread from us. I have raised this issue with our lead developer and I'm hopeful he will be able to shed some further light on the situation.

    Can you confirm the resolution of the monitor/screen being used? I'm wondering if this issue only related to screens using a higher resolution.

    Jim, I'd like to thank you for the thorough description and accompanying screenshots.

    Info, I'd also like to thank you for re-raising this issue. I have located the other thread you started. If you would prefer, we can revive that one but it might be best to keep all troubleshooting in this thread.

    Ian O
    Infinite Kind Support

  15. 13 Posted by info on 28 May, 2018 11:14 AM

    info's Avatar

    Please keep using this thread.. and here is my resolution information. Thank you.

  16. 14 Posted by Jim on 28 May, 2018 03:23 PM

    Jim's Avatar

    Ian O, my screen resolution is 1680 x1050, so my problem is not a Java high DPI issue (as described here). Instead my problem is caused by Moneydance's included Java (a Java version or setting issue).

    I looked into the solution provided by amaxware here and it does solve my problem. Here are some more details on this workaround:

    Prior to the change "Help->Console Window" showed:

    Starting Moneydance 2017.7.2 (1672) at Mon May 28 09:25:29 CDT 2018
    OS: Linux 3.10.0-862.3.2.el7.x86_64 amd64
    Java: 1.8.0_144 (Oracle Corporation)
    
    I then closed Moneydance and from the terminal I ran
    export INSTALL4J_JAVA_HOME_OVERRIDE=/etc/alternatives/jre
    
    And now when I start Moneydance by running /opt/Moneydance/Moneydance from the same terminal everything works correctly. "Help->Console Window" shows:
    Starting Moneydance 2017.7.2 (1672) at Mon May 28 09:28:45 CDT 2018
    OS: Linux 3.10.0-862.3.2.el7.x86_64 amd64
    Java: 1.8.0_171 (Oracle Corporation)
    
    I'm using OpenJDK 1.8.0.171-8.b10 on CentOS 7.5:
    $ yum list installed '*openjdk*'
    java-1.8.0-openjdk.x86_64                1:1.8.0.171-8.b10.el7_5        @updates
    java-1.8.0-openjdk-headless.x86_64       1:1.8.0.171-8.b10.el7_5        @updates
    
    Of course as soon as I close that terminal window my INSTALL4J_JAVA_HOME_OVERRIDE environment variable goes away. To make this Java override permanent (until the next time you update Moneydance) you must (as root) edit "/opt/Moneydance/Moneydance" and change this line (fourth from the top for me) from:
    # INSTALL4J_JAVA_HOME_OVERRIDE=
    
    to:
    INSTALL4J_JAVA_HOME_OVERRIDE=/etc/alternatives/jre
    
    Manually editing this file isn't a great user experience (and most won't know to do this), so I look forward to this being permanently fixed. And while you're at it, I assume it'd be trivial to fix the other (unrelated) minor issues I reported here.
  17. 15 Posted by info on 28 May, 2018 11:03 PM

    info's Avatar

    Thanks Jim --- I think this did work! The first time I tired it, it did not work at all. I only had the 1.8.0 headless jdk installed, so the Moneydance UI did not even show up, but the Java process was still running. Next, I installed openjdk and I think the key could be the xorg-x11-fonts addition..

    sudo yum install java-1.8.0-openjdk
    (1/3): ttmkfdir-3.0.9-54.fc28.x86_64.rpm        260 kB/s |  60 kB     00:00    
    (2/3): java-1.8.0-openjdk-1.8.0.171-4.b10.fc28. 677 kB/s | 245 kB     00:00    
    (3/3): xorg-x11-fonts-Type1-7.5-19.fc28.noarch. 1.3 MB/s | 521 kB     00:00
    

    I have a little script that I used to run Moneydance -- so this was not a big deal...

    #!/bin/bash
    cd /opt/Moneydance1676
    export INSTALL4J_JAVA_HOME_OVERRIDE=/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.171-4.b10.fc28.x86_64/jre
    ./Moneydance
    rm -rf ~/Downloads/.qfx
    rm -rf ~/Dropbox/MoneyDance2018/moneydance.moneydance/safe/tiksync/out/2018*
    

    Thanks again.. It is so nice to actually be able to read some of the bar graphs again!!!

  18. 16 Posted by Jim on 29 May, 2018 02:43 AM

    Jim's Avatar

    Yeah, I didn't realize how much I missed the missing text. Now that I have the full text displaying again it looks so much nicer.

  19. Support Staff 17 Posted by Ian O on 29 May, 2018 09:53 AM

    Ian O's Avatar

    Jim, thanks for your thorough explanation of the corrective steps you took. I agree that carrying out this procedure from customer perspective is a bit much. I'll relay the information you have provided to our lead developer as it might be useful to him. I'll also make sure that your other concerns and suggested improvements are raised.

    info, I'm very glad to read that you were able to get Moneydance displaying correctly following Jim's directions.

    Ian O
    Infinite Kind Support

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • pleaseEnterYourPassword.png 10.3 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac