Moneydance 2017.3 bug with two fingers on Mac Air trackpad

RSN's Avatar


19 Jul, 2017 05:11 PM

To perform the right click of a mouse on a Mac Air track pad, you need to use two fingers simultaneously. This does not work with Moneydance after I upgraded to the Moneydance 2017.3. It worked fine on version 2014.5. It works with other applications on my Mac.

The problem occurs when I try to right click on a register entry to get the menu to mark an item cleared. The menu flashes briefly.

Please fix this bug ASAP.

  1. 1 Posted by RSN on 19 Jul, 2017 05:13 PM

    RSN's Avatar

    BTW, my Mac is macOS Sierra - version 10.12.5

  2. Support Staff 2 Posted by Henry on 20 Jul, 2017 10:24 AM

    Henry's Avatar


    Thank you for contacting us.
    It's possible that the newer version of Java changed the sensitivity of the trackpad, we can try two options:
    1) An alternative to the double-click is CTRL + click.
    2) Open your System Preferences > Accessibility > Mouse and Trackpad > Double-click speed and adjust the slider to match your double-click. You may need to adjust it multiple times until you get the best configuration. The same can be tested with the Spring delay setting, moving it to long.

    As far as I've seen Java already changed the scrolling speed that was an issue before, I'm hoping for an additional change regarding the double-click, but until then this is a good option.

    Infinite Kind Support

  3. 3 Posted by RSN on 25 Jul, 2017 04:39 PM

    RSN's Avatar

    Thank you Henry.

    I will use CTRL + click until the fix is available.

  4. 4 Posted by RSN on 13 Aug, 2017 04:54 PM

    RSN's Avatar

    I see errors for downloading stocks quote. On retry the quote works. Might be quote time out delay is too short.

  5. Support Staff 5 Posted by Henry on 14 Aug, 2017 01:33 PM

    Henry's Avatar


    A Yahoo support representative has confirmed that Yahoo Finance API has been discontinued.
    From the changes that have been made, it seems like Yahoo is trying to prevent people from automated downloading like Moneydance (and so many others) are doing.

    Our lead developer has mentioned that we may be able to make a change, that means the Moneydance connection will pose as a browser, rather than a program. This may allow the connection. However, it seems very likely that this will turn into a 'cat-and-mouse' game.

    The current workaround is to navigate to Extensions and Select Quotes and Exchange Rates and change the Historical Security Prices to Google Finance. If certain prices are missing after that, you can download the quotes in a cvs file and import them by navigating to Tools > Securities > Edit then Import.

    You can also update the current prices through the Security Price Entry extension in the Extensions menu.

    We are looking into other services we can use instead to resume the automatic downloads.

    Infinite Kind Support

  6. System closed this discussion on 13 Nov, 2017 01:40 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

19 Jul, 2018 01:14 PM
19 Jul, 2018 12:13 PM
19 Jul, 2018 12:05 PM
19 Jul, 2018 02:11 AM
19 Jul, 2018 01:13 AM