Data corruption during upgrade

buyashim's Avatar

buyashim

09 Jul, 2017 05:05 PM

Hello Moneydance team,

About a month ago on a private discussion thread on this forum, I had submitted real accounting data files from MD 2014, which could then be imported into MD 2017 to witness massive data corruption, simply by looking at the totals of the liability accounts.

I did not get any reply to my post there so maybe that thread is dead. Thus, I am re-posting this message as a new thread for the support team to take notice. I wanted to know if someone is working on fixing that problem or is that not a priority for now.

Thank you for your time.

Sincerely,
Ashim Jain
Los Angeles

  1. 1 Posted by boreham on 10 Jul, 2017 05:25 AM

    boreham's Avatar

    Just a user, not support, but my first questions would be to ask you are syncing at all, and where your data file is located. If you are and previously had the MD data file in Dropbox it needs to be moved.

    See these threads (for example) for explanation and discussion:

    http://help.infinitekind.com/discussions/problems/34647-had-a-chall...

    and this one:

    http://help.infinitekind.com/discussions/suggestions/10342-error-lo...

    I had the problem of very incorrect totals when first changing to MD2017 because I had kept the MD data files in Dropbox, causing double syncing (the old way and the new MD2017 sync engine).

    Moneydance 2017 has been updated within the last month....are you using MD 2017.4 build 1623?

  2. 2 Posted by buyashim on 10 Jul, 2017 05:39 AM

    buyashim's Avatar

    Thank you for your attempt to help me boreham.

    I am not syncing anywhere (no Dropbox and not even the MD app).

    I had used MD2017 (first version) in this last attempt more than 1-2 months ago.

    However, about a year ago, I had tried to upgrade from my current MD 2014.5 (980) to 2015.7 (1358). It showed the exact same symptoms. At that time, I had brought this to the notice of MD support staff, although I could not send real data due to privacy reasons.

    As it has happened again in 2017, it appears it's one of those very elusive and special condition bugs that happen only with certain types of transactions which the developers may never have envisioned (and thus were not tested). I don't think it should be hard to trace since the bug is repeatable, is drastic and limited to only liability accounts. They should be able to find the particular transactions that are causing the bug.

    So I doubt the 2017.3 will help much but nonetheless, I shall give it a try tomorrow. Thanks again for your suggestion.

  3. 3 Posted by boreham on 10 Jul, 2017 05:43 AM

    boreham's Avatar

    Oh well, worth a try!

    BTW the very latest builds are available here:

    http://infinitekind.com/preview

    EDIT The current latest preview build is build 2017.4 b1623, and the latest current rerelease is 2017.3 b1622

  4. 4 Posted by buyashim on 13 Jul, 2017 05:53 AM

    buyashim's Avatar

    I've tried the latest build too -- bug is still there.

    The bug affects non-liability accounts also. And the difference can be in millions not just small errors.

    I'm uploading two screenshots of some liability account totals, shown in both MD2014 and MD2017. See the massive errors.

  5. 5 Posted by buyashim on 15 Jul, 2017 02:12 AM

    buyashim's Avatar

    Will somebody from the developers reply to this problem please? This is not a small error and will affect numerous people who will upgrade.

    I dug down further into account entries to see where the errors were occurring at the transaction level. It is quite amazing that the errors are not just in the liability accounts but in all types of accounts (Bank, Assets, ...)

    Also, the errors are of completely random nature. Examples of what errors have done--

    • Amount changed in a transaction (no pattern of change, completely arbitrary)

    • One account of a transaction changed to some other (one account of the two accounts that each transaction comprises of)

    • Amount of one line item in a Split transaction changed

    • I think I even saw two new transaction entries created although this might be the same as the 2nd bullet above. ....

    In a second try, I did the conversion of data from 2014 to 2017 by deleting all previous backup files and all other files and folder in the data folder except the root.mdinternal file, just to make sure the converter was not picking up any old data from other files. This didn't make any difference.

    **** REQUEST THE FAVOR OF A REPLY EVEN IF YOU DO NOT WANT TO FIX THIS BUG ****

    Thanks

  6. Support Staff 6 Posted by Ian O on 15 Jul, 2017 11:03 AM

    Ian O's Avatar

    Hi Ashim,

    Please accept my apologies again for the delayed response. I've now responded on your original private thread here.

    Hopefully we can troubleshoot this issue and get to the bottom of the strange issue you have encountered when upgrading.

    Ian O
    Infinite Kind Support

  7. 7 Posted by buyashim on 15 Jul, 2017 01:40 PM

    buyashim's Avatar

    Hi Ian,

    Working late into the night yesterday and trying to manually search and fix each entry that was corrupted, I think I may have narrowed down the bug for you.

    It seems like all the corrupted entries are transactions that were once modified by me in the past (in MD 2014 of course). This makes me think that your data converter picked up the old entries, those made even years ago, from the inside of some kind of an "UNDO buffer" and disregarded the new entries.

    That also explains why the corruption is of all kinds because I have made changes to transaction amounts, changed accounts, changed split entries, etc.

    Hope this will save you time to finally nail the bug.

    Ashim

  8. 8 Posted by Mark on 16 Jul, 2017 08:24 AM

    Mark's Avatar

    I'm having the same problems, consistently since the last version.
    Transactions are entered correctly but the sum totals (net worth etc) are completely wrong.
    When I go in to the detailed list of transactions in reports, I see why: every transaction displays with numbers in the millions, billions or trillions, despite the actual transactions entered in the registers being normal numbers (in the tens or hundreds).

    This resembles the currency bug I'd previously seen (which I'm still not sure has been fixed) but is much more widespread in scope and is making Moneydance nearly unusable for summary reporting.
    Please, somebody, look into this urgently!

  9. 9 Posted by buyashim on 17 Jul, 2017 05:02 PM

    buyashim's Avatar

    boreham (and Infinitekind support),

    I don't know if you'll get this message. I downloaded the latest Beta version after your suggestion above.

    It wiped out (deleted) all the attachments (the documents attached with certain transactions) during the translation of data from 2014 to 2017.3b.

    Then I repeated the translation again with the officially released 2017.3, and the attachments remained intact. So, the Beta versions appear to be half-baked and in this poor state, they shouldn't even be released to the public.

    Now I am worried that the other accounting books (of other clients) that I converted using the Beta version and having manually fixed all entries after spending hours might also have this and other problems. A lot of time lost I guess. NEVER TO TRY BETA VERSIONS although that might be no security if the main releases also have bugs.

    :-(

  10. 10 Posted by boreham on 17 Jul, 2017 05:11 PM

    boreham's Avatar

    Sorry to hear that. I have never experienced a problem with a Preview build.

    But I don't use attachments and nor have I converted from 2014 to 2017, so maybe you have exposed a bug which wouldn't have affected me.

    Guess its always safer to use released builds, and have backups you can revert to.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac