Can't Print Checks

singerdf's Avatar


03 Apr, 2017 12:28 PM

Starting this morning, I cannot print any checks. It opens the first window. You select what you want printed but when click on Print it hangs. The application actually goes into an unresponsive state. I upgraded the app (Moneydance 2017), restarted the computer, repaired permissions and made sure printer sharing was on. Nothing has worked.

I am running 10.12.4 which was released and installed on March 28. I have used Moneydance since then but not printed.

I am stuck,


Showing page 2 out of 2. View the first page

  1. 31 Posted by dwg on 02 May, 2017 10:34 PM

    dwg's Avatar

    I believe that IK support have made a mistake by leaving so many threads open on this one topic, I would estimate there are 20+ threads on this topic.

    The latest update I have seen is on:

    I would suggest that IK support direct users to ONE thread on the topic and close other threads this keeping all information and any updates on this in one place.

  2. 32 Posted by puybaret on 03 May, 2017 06:58 AM

    puybaret's Avatar

    To MoneyDance team (I didn't find any direct email to write you): if you don't find a solution in the coming weeks, may I suggest that you propose at least a "Print to PDF" feature like in Sweet Home 3D (even if this feature is unfortunately not activated in the macOS version of the application, where the PDF feature is supposed to work)?
    See HomePDFPrinter class at based on the latest GNU LGPL version of iText available at

    Hope this will help,
    Emmanuel Puybaret

  3. 33 Posted by peter.michaelso... on 03 May, 2017 12:35 PM

    peter.michaelson's Avatar

    Hello, EP - the hang takes place between the MD print screen and the MacOS print screen where the "Print to PDF" button comes up. So it's no help. By the time you get that far, if you do, you can print to printer OK.

    - Peter Michaelson
    from Warwick, RI
    Sent from my iPad

  4. Support Staff 34 Posted by Jenny on 12 May, 2017 10:49 AM

    Jenny's Avatar

    Hi all,

    Please accept my sincere apologies for the lack of consistent updates from the team on this thread. As this problem is effecting so many customers, we have many open discussions about this issue. I wanted to ensure you have all be made aware of the most recent update posted by our lead developer, Sean Reilly. I have copied the comment below -

    "There is currently a bug in Apple's sandbox container that is specific to mac OS 10.12.4 and blocks any connection we try to make to the printing system. The problem is also in the current mac OS 10.12.5 beta. We have contacted Apple with the specifics of the problem and are awaiting confirmation and a resolution, hopefully in time for 10.12.5.

    The problem sometimes appears that Moneydance has completely frozen and can last for several minutes. However, Moneydance will always un-freeze and resume operation, often with a working print settings window visible, but it often takes several minutes to appear.

    I've tried every workaround that I can think of and have only been able to reduce but not eliminate the delay. A version with the delay reduction will be available soon, but the delay is still a problem so we're still looking for better workarounds.

    In the meantime, if you have this problem and would like to print a report or graph I recommend using the "Save" function to save reports to html or graphs to an image file, and then using the Preview app or a web browser to print the saved file."

    Infinite Kind Support

  5. 35 Posted by singerdf on 12 May, 2017 11:29 AM

    singerdf's Avatar

    Thank you. Very much appreciated. Fingers crossed that the coders at Apple know what they changed.

  6. 36 Posted by singerdf on 17 May, 2017 01:23 PM

    singerdf's Avatar

    Thanks for the update.

    I updated my OS today and no change. What a mess.

  7. 37 Posted by george.dobbs on 17 May, 2017 11:34 PM

    george.dobbs's Avatar

    Likewise quick test on 10.12.5 shows no change

    Sent from my iPhone

  8. 38 Posted by singerdf on 13 Aug, 2017 03:54 PM

    singerdf's Avatar

    I have been very patient in regards to this issue. I downloaded 2017.4 yesterday and there is no change. Can you provide an update?


  9. Support Staff 39 Posted by Ian O on 30 Aug, 2017 11:27 AM

    Ian O's Avatar

    Hi All,

    I'd like to apologies again for the long wait you have all had for a solution to this issue. As previously stated we believe we are closing in on a fix for this but it has regrettably taken much longer than we anticipated. I'd like to assure you all that we are actively working on a resolution to this issue and still exploring various options, including seeking external expertise which we hope will speed things up considerably. We still consider resolving this issue our top priority and hope to have news of definitive progress in the near future.

    Ian O
    Infinite Kind Support

  10. 40 Posted by singerdf on 08 Oct, 2017 03:10 PM

    singerdf's Avatar

    It looks like this issue is fixed once you upgrade to High Sierra. NO idea what changed but I am thankful for the fix.


  11. 41 Posted by george.dobbs on 09 Oct, 2017 11:02 PM

    george.dobbs's Avatar

    I can confirm that the upgrade to High Sierra fixed the problem on my
    computer as well.

    Sent from Postbox

  12. 42 Posted by wjr on 17 Oct, 2017 05:24 AM

    wjr's Avatar

    I agree. Upgrading to High Sierra fixes the problem.

  13. System closed this discussion on 16 Jan, 2018 05:30 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac