Please Note: We've moved Moneydance and SyncSpace's support to a new location. Please join us for support and discussion at infinitekind.zendesk.com.

Moneydance not opening

Andrew  Hulmes's Avatar

Andrew Hulmes

18 Aug, 2010 06:39 PM

I have used Moneydance successfully for the last few months but when I tried today it wouldn't open. When I try to open from any of the various shortcuts in the Start Menu, Taskbar and Desktop all I get is the Moneydance icon on the taskbar. Nothing happens when I click on this but when I hover over it shows a blank reduced window with the file path " Root Account - C:\Users\Andrew\Documents\Test.md ". I have tried the usual IT fallback of turning the machine off and back on again to no avail.

The short cut target is "C:\Program Files (x86)\Moneydance\Moneydance.exe" As it happens when I try to open the program I do get the Moneydance Updater window but when I try to upgrade I get an error message (see attached screen print of message)

I am running Windows 7 Home Premium with a Pentium Dual Core processor with a 64-bit OS

  1. 2 Posted by Andrew Hulmes on 18 Aug, 2010 06:53 PM

    Andrew Hulmes's Avatar

    Just discovered the following error log notepad file:

    Starting Moneydance 2010r2 (735)
    Settings Folder: C:\Users\Andrew.moneydance
    OS: Windows 7 6.1 x86
    Java: 1.6.0_16 (Sun Microsystems Inc.)
    using public key: com.moneydance.security.DSAPublicKeyImpl@1c20eb7
    Retrieving signature
    os: Windows 7
    osversion: 6.1
    javaversion: 1.6.0_16
    classpath: C:\Program Files (x86)\Moneydance.install4j\i4jruntime.jar;C:\Program Files (x86)\Moneydance.\moneydance.jar;C:\Program Files (x86)\Moneydance.\appsrc.jar;C:\Program Files (x86)\Moneydance.\jfreechart-1.0.13.jar;C:\Program Files (x86)\Moneydance.\jcommon-1.0.16.jar;C:\Program Files (x86)\Moneydance.\tablelayout.jar;
    pathseparator: ;
    laxdir: null
    installing cross-platform update
    Warning: error making backup: java.io.FileNotFoundException: C:\Program Files (x86)\Moneydance.\moneydance.bak (Access is denied)
    java.io.FileNotFoundException: C:\Program Files (x86)\Moneydance.\moneydance.bak (Access is denied)

    at java.io.FileOutputStream.open(Native Method)
    at java.io.FileOutputStream.<init>(Unknown Source)
    at java.io.FileOutputStream.<init>(Unknown Source)
    at com.moneydance.modules.features.updater.Upgrader.copyFile(Upgrader.java:31)
    at com.moneydance.modules.features.updater.Upgrader.installUnknownFile(Upgrader.java:110)
    at com.moneydance.modules.features.updater.Upgrader.installFile(Upgrader.java:75)
    at com.moneydance.modules.features.updater.MoneydanceUpdater.installNewFile(MoneydanceUpdater.java:137)
    at com.moneydance.modules.features.updater.MoneydanceUpdater$Downloader.run(MoneydanceUpdater.java:272)
    at java.lang.Thread.run(Unknown Source)
  2. 3 Posted by Viv Fox on 18 Aug, 2010 07:11 PM

    Viv Fox's Avatar

    I have also used moneydance since May - no problems (though I preferred Quicken - sorry!) I now get a message saying missing shortcut. My IT man said reinstall the program and I have but no difference. Ideas please

  3. Support Staff 4 Posted by Ben Spencer on 18 Aug, 2010 07:23 PM

    Ben Spencer's Avatar

    The first problem seems to be that Moneydance is starting up minimized. Moneydance starts up minimized if it was minimized when you closed it. You should maximize it by running Moneydance then hover over the item on the taskbar and wait until you see the thumbnail. Then right click on the thumbnail and select maximize.

    The second problem seems to be unrelated. This looks like your tried to run an automatic update and your user did not have write permission to the programs folder.

    Sincerely
    Ben Spencer

  4. 5 Posted by Andrew Hulmes on 18 Aug, 2010 10:04 PM

    Andrew Hulmes's Avatar

    Thanks, that's solved the problem. It has also updated successfully after selecting "Run as Administrator"

    Regards,

    A

  5. Ben Spencer closed this discussion on 18 Aug, 2010 11:18 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac