Interference with Airplay

andrew's Avatar

andrew

15 Sep, 2013 12:36 PM

Is it possible moneydance can interfere with Apple airplay?

Every time I start moneydance my airplay music starts to stutter and the music comes in and out. I wouldn't believe this was possible, but it is seems to be a repeatable problem. It also only happens on by Bose Sound dock (which connects wirelessly to my network)

I have recently installed the Moneydance updater - could this do it. I also use the stocks and share updater.

  1. Support Staff 1 Posted by Ethan on 15 Sep, 2013 01:02 PM

    Ethan's Avatar

    Hello,

    The only thing I can think of that would possibly cause something like this is the network synchronizer extension if you are using wi-fi sync. If it is set up to do that, it scans your wireless network looking for mobile devices, which could conceivably cause such a problem when it is doing that. However, I don't believe we have had any reports of this happening. Other than that, I can't think of what would be causing this, but I'll ask our developers if they have any ideas. Moneydance doesn't pull enough internet traffic when starting to cause something like this, unless your network connection is very slow.

    Ethan Tupelo
    Moneydance Support

  2. 2 Posted by andrew on 15 Sep, 2013 01:46 PM

    andrew's Avatar

    I have uninstalled all the extensions and the problem still occurs - weird.

    Do you have the Little Snitch network monitoring tool? If so I can send you an interactive snapshot showing the increase in network traffic when I start and stop Moneydance. Static version of pic attached attached. The increases and decreases in traffic (shown in red) correspond with starting and stopping Moneydance and the deterioration of the sound to the airplay speaker.

    Hope this helps.

    Andrew

  3. 3 Posted by -Kevin N. on 15 Sep, 2013 02:21 PM

    -Kevin N.'s Avatar

    Hi Andrew,

    Just a hunch...

    If you are experiencing network traffic on Moneydance startup, check in Preferences on the Network tab to see if 'Automatically Download in Background' is check-marked.

    -Kevin N.

  4. 4 Posted by andrew on 15 Sep, 2013 02:26 PM

    andrew's Avatar

    HI Kevin
    This option is not checked. I assume this is right option.
    Best wishes
    Andrew

  5. 5 Posted by -Kevin N. on 15 Sep, 2013 02:36 PM

    -Kevin N.'s Avatar

    Hi Andrew,

    Having that option check-marked instructs Moneydance to download your online banking data on startup. I thought that that might be the network traffic that you were seeing.

    -Kevin N.

  6. 6 Posted by andrew on 16 Sep, 2013 07:08 AM

    andrew's Avatar

    Hi Kevin.
    I don't use the online banking data download so I have never enabled this.
    I am also puzzled why I have not noticed this before. It is a mystery.
    Andrew

  7. 7 Posted by Scott Meehan on 16 Sep, 2013 04:48 PM

    Scott Meehan's Avatar

    Hi Andrew,

    Are you using Dropbox syncing with Moneydance? Or the Quotes and Rates extension to download stock and exchange rate updates? Those might be causing the internet traffic that you're seeing.

    Can you also send us the output of your console log? This can be found by going to Help -> Console window in Moneydance, then clicking the "Copy to clipboard" button and pasting the output to us here.

    Scott Meehan
    Moneydance Support

  8. 8 Posted by andrew on 16 Sep, 2013 05:54 PM

    andrew's Avatar

    Hi

    I do use dropbox - but not for syncing moneydance. I have removed all the extensions except detailed buddget and investment reports - I did use the stocks and exchange rate update.

    This was the console log:

    Starting Moneydance 2012.5 (862) at Mon Sep 16 18:49:17 BST 2013
    Settings Folder: /Users/andrewk/Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance
    OS: Mac OS X 10.8.4 x86_64
    Java: 1.7.0-moneydance2012-888 (Oracle Corporation)
    Is in sandbox: true; restricted file access: false
    opening last file: Joint Accounts

    That was it.

    Hope this helps.

    Andrew

  9. 9 Posted by Scott Meehan on 17 Sep, 2013 01:16 AM

    Scott Meehan's Avatar

    Hi Andrew,

    I missed earlier that you said that you were using the Moneydance updater extension, so that could have been the cause of the internet traffic since it'll check for a new version of Moneydance on startup.

    Scott Meehan
    Moneydance Support

  10. 10 Posted by andrew on 17 Sep, 2013 07:18 AM

    andrew's Avatar

    Hi Scott

    I have uninstalled the Moneydance updated and still get the problem.
    Andrew

  11. 11 Posted by Scott Meehan on 19 Sep, 2013 05:34 PM

    Scott Meehan's Avatar

    Hi Andrew,

    Do you have the HandyBank extension installed? Is the Airplay streaming audio from the internet, such that network traffic might disrupt it at times? How fast is your Wifi network?

    I'm a little stumped on this one at the moment.

    Scott Meehan
    Moneydance Support

  12. 12 Posted by andrew on 21 Sep, 2013 09:48 AM

    andrew's Avatar

    Hi
    I do not have the Handybank extension installed. The audio is coming from iTunes on my Mac. The Wifi network is "n" standard and the access points are all Apple, so it should be about as good as it can be.

    I too am a little stumped. I will test again this weekend to see if it is still occurring and can gather any more clues.

    Andrew

  13. System closed this discussion on 31 Mar, 2015 04:06 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac