HSBC UK Credit Card transactions not matching from QIF files

larry's Avatar


26 Apr, 2018 08:46 AM


HSBC UK have unilaterally removed OFX format from the transaction download for current credit card transactions. When importing, the QIF shows every transaction for the current month, and these have to be re-matched every time. Is there anything I can do to stop this issue? I've complained to HSBC …

BTW the transactions are available in OFX for previous months...

  1. Support Staff 1 Posted by Jenny on 26 Apr, 2018 01:38 PM

    Jenny's Avatar

    Hi Larry,

    Sorry to hear about the issues you've encountered.

    The OFX file will contain unique transaction ID's - if any transactions have already been downloaded, Moneydance recognises the ID and does not import the transaction again.

    Unfortunately QIF files don't include this same feature.

    When downloading in the QIF file format, you should be able to choose the date range for the file. Do you see this option on your banks site? Some banks provide a date option of 'Since last download' - this means you don't need to manually set the date range each time.

    Infinite Kind Support

  2. 2 Posted by larry on 27 Apr, 2018 02:27 PM

    larry's Avatar

    Thanks Jenny. I've finally got through to HSBC, and their "intention" is to remove the .OFX format. I've escalated this as a complaint and would suggest as many HSBC UK customers do this as well

  3. 3 Posted by larry on 14 May, 2018 06:00 AM

    larry's Avatar

    I thought I would update here, as I've had a fairly lengthy correspondence with HSBC UK. They have only removed OFX downloads from the credit card accounts, as there is a technical issue. Once this is resolved, they will be reinstating..,

    Good news, although why they can't tell us I don't know!

  4. larry closed this discussion on 14 May, 2018 06:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac