connecting to Fidelity Investments

paul.charp's Avatar

paul.charp

08 Apr, 2018 06:49 PM

i'm having trouble connecting to my fidelity accounts. anyone out there have any success and/or suggestions? I have also tried importing the information from a csv file with no success.

  1. 1 Posted by -Kevin N. on 08 Apr, 2018 07:12 PM

    -Kevin N.'s Avatar

    Hi Paul,

    I have 4 accounts at Fidelity. 1 brokerage account and 3 IRA accounts. I have no problem using direct-connect to import data from Fidelity.

    Are you receiving any error message when you try to connect?

    CSV files can not be imported into investment type accounts in Moneydance.

    -Kevin N. (not a member of MD support)

  2. 2 Posted by Mike V. on 08 Apr, 2018 07:16 PM

    Mike V.'s Avatar

    Kevin,

    Would you please outline the procedure you are using to use direct-connect to import data from Fidelity Investments. Thank you.

  3. 3 Posted by paul.charp on 08 Apr, 2018 07:18 PM

    paul.charp's Avatar

    I have not received any error messages. I did see the message (from you?) regarding a preview version of MD.  That seems to be working.  Did you have to set up a specific MD account for each of your Fidelity accounts?

     

    -- paul charp

     

    From: "-Kevin N." <[email blocked]>
    Reply-To: <[email blocked]>

  4. 4 Posted by paul.charp on 08 Apr, 2018 07:20 PM

    paul.charp's Avatar

    I was following the user guide. 1st set up the account, then go to the online menu drop down, etc.  I also saw someone else’s post regarding a preview version of MD that was working. I am trying that now.

     

    Thanks for your quick response. Stay tuned

     

    -- paul charp

     

    From: "Mike V." <[email blocked]>
    Reply-To: <[email blocked]>

  5. 5 Posted by Vince Hietala on 13 Apr, 2018 07:02 PM

    Vince Hietala's Avatar

    I've found that something's gone wrong this week with the Fidelity NetBenefits connector (Fidelity Investments still works). Possibly this is related...
    Vince

    Partial Error message:
    Bank Name: Fidelity NetBenefits

    A communication or parsing error occurred. This could be the result of a network problem, a proxy error, or misconfigured server.
    Error Description: java.io.IOException: HTTP Error:400 Bad Request
    java.io.IOException: HTTP Error:400 Bad Request
    at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.sendMessage(OFXConnection.java:2740)
    at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.sendMessage(OFXConnection.java:2565)

  6. Support Staff 6 Posted by Ian O on 14 Apr, 2018 10:41 AM

    Ian O's Avatar

    Hi Vince,

    Sorry to hear of the issue you have encountered while using Moneydance. Can you let me know what version of Moneydance you are using? You can check this detail within Moneydance by navigating to Help --> About Moneydance (Moneydance --> About Moneydance on a Mac).

    Ian O
    Infinite Kind Support

  7. 7 Posted by Vincent Hietala on 14 Apr, 2018 02:38 PM

    Vincent Hietala's Avatar

    2017.7.1 (1671)

    Thanks for looking into this.

    Vince

  8. Support Staff 8 Posted by Ian O on 14 Apr, 2018 02:41 PM

    Ian O's Avatar

    Thanks Vince. From what I'm finding online, it seems Moneydance is not the only personal finance software this is effecting. It would appear Fidelity are encountering difficulties maintaining Direct Connect services. I'll continue to monitor the situation and update our connection information if needed. I'll update you as soon as there have been any developments. Please let me know if I can be of any assistance in the meantime.

    Ian O
    Infinite Kind Support

  9. 9 Posted by John on 14 Apr, 2018 03:35 PM

    John's Avatar

    I am also on 1671 and about 3 days ago, Fidelity NetBenefits stopped working throwing off the error messages identified in earlier posts. I have another software program for my investment portfolios and it stopped downloading information about a month ago, and then about 3 days ago, threw off a different error message indicating invalid user signon. I talked to Fidelity NetBenefits on this topic and they basically said if it ain't Quicken we can't help you. Recently as I've researched this problem, it is becoming more evident that even Quicken is having problems. Perhaps Fidelity NetBenefits will offer some help now.

    Of course, I'll always accept the kind help from the MD team if a solution shows up. I had hopes that 1670 or 1671 would solve the problem (referenced in many other posts within the last 30 days), but I am on 1671, so looks like Fidelity has indeed changed their security protocols.

  10. 10 Posted by fellforce on 14 Apr, 2018 05:08 PM

    fellforce's Avatar

    Started seeing this problem with Fidelity NetBenefits earlier this week.

  11. 11 Posted by webyan on 14 Apr, 2018 05:43 PM

    webyan's Avatar

    I am having problems downloading from NetBenefits also starting this week. I get this message:

    Additional information from the server:
    Error occurred logging in

    I am using 2017.7.1 (1671)

  12. 12 Posted by webyan on 16 Apr, 2018 10:50 PM

    webyan's Avatar

    Downloads worked for me today from Fidelity NetBenefits. I am using 2017.7.1 (1671) on MacOS.

  13. 13 Posted by paul.charp on 18 Apr, 2018 12:21 AM

    paul.charp's Avatar

    I was able to connect and download data from Fidelity. It turns out they were having problems with their OFX server.

     

    But now I have another question. When I downloaded the data, all transactions were entered in the deposit column although several were deposits and a withdrawal for the same amount. This results in double entries. Any suggestions besides manually correcting all the entries (there are many in my multiple accounts).  Also I have transactions from within the same account (the cash account) to purchase securities. These show up in an automatically established un-named bank account and I have not found an efficient method to establish intra account transactions.

     

    Thanks

     

    paul

     

    From: "-Kevin N." <[email blocked]>
    Reply-To: <[email blocked]>

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac