Problems w/ USBank direct connect

hmd's Avatar

hmd

12 Mar, 2019 07:31 PM

Hi:
Yesterday, in a discussion now deleted, someone complained about their direct connection to USBank suddenly not working. I also have the problem, using Moneydance 2017.10 (1706).

The console log ends with :
FI refresh is forced
uh oh, we've gotten some OFX with no headers: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Draft//EN">
java.io.IOException: HTTP Error:400 Bad Request
at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.sendMessage(OFXConnection.java:2745)
at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.sendMessage(OFXConnection.java:2569)
at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.getTransactions(OFXConnection.java:980)
at com.moneydance.apps.md.view.gui.OnlineManager.downloadTransactions(OnlineManager.java:554)
at com.moneydance.apps.md.view.gui.OnlineManager.downloadTransactions(OnlineManager.java:469)
at com.moneydance.apps.md.view.gui.acctpanels.BankAcctPanel$DLTxnsRunnable.run(BankAcctPanel.java:474)
at com.moneydance.apps.md.controller.BackgroundOpsThread.run(BackgroundOpsThread.java:136)

I've created a new connection, per the troubleshooting web page, with the same result. I've called USBank and they say nothing has changed on their end and it is not a common problem. They also said they have no record of me logging in since it last worked a week ago. So, I'm not getting into their system far enough to be logged.

Any ideas how to get this working again?

thx, hf

  1. 1 Posted by sunjunkie-sb on 12 Mar, 2019 08:50 PM

    sunjunkie-sb's Avatar

    I have the same problem. USBank connection stopped working about 5 days ago or so. I've upgraded to Moneydance 2019 and same result. Moneydance shows the attached error screen which appears to be the same underlying error as @hmd.

    I've tried to create a new connection and also called USBank.

  2. 2 Posted by Olle Lindqvist on 12 Mar, 2019 10:01 PM

    Olle Lindqvist's Avatar

    Same problem :-(

  3. Support Staff 3 Posted by Henry on 13 Mar, 2019 01:57 PM

    Henry's Avatar

    Hi All,

    Thank you for contacting us.
    We're receiving quite a few reports of problems with the US Bank connection, and we're working to get this resolved now. I have flagged this discussion so you'll be notified when this is fixed, and we'll provide the steps you need to get connected again.

    Henry
    Infinite Kind Support

  4. 4 Posted by Ray Callahan on 13 Mar, 2019 04:13 PM

    Ray Callahan's Avatar

    I have the same issue. Prior to coming on this site, I contacted US Bank. They troubleshooted but came up with the same result. Please notify when this issue is fixed.

  5. 5 Posted by avp2 on 13 Mar, 2019 06:58 PM

    avp2's Avatar

    Got the below (partial message) from USBank support today. As of now, they do not seem to know they even have a problem.

    ..........I was unable to locate this as a known issue .........

  6. 6 Posted by Ray@WPS on 13 Mar, 2019 07:06 PM

    Ray@WPS's Avatar

    US Bank says the problem is not at their end, but the Moneydance connectivity is the issue.

  7. 7 Posted by jdm_80 on 13 Mar, 2019 09:40 PM

    jdm_80's Avatar

    Ditto - just getting my name on the list for notification.

    Called US Bank yesterday. They were searching their trouble database assuming I am connecting via Quicken since I pay a monthly fee that says, "Quicken Access Fee". When they searched against Moneydance the lady said, "Oh, we've had a few problems logged in the last two weeks with that name, but it doesn't seem to be on our end."

  8. 8 Posted by cawgolf1 on 13 Mar, 2019 10:05 PM

    cawgolf1's Avatar

    Add me to the list. Nothing has downloaded since March 7. Called US Bank like the other folks but they have no record of me even getting in. Please notify me when the issue is resolved. Thank you!

  9. 9 Posted by avp2 on 14 Mar, 2019 08:36 PM

    avp2's Avatar

    I just got US Bank OFX to work. It appears they changed the server URL and FI ORG. Use the online setup>new>advanced window to enter Name, FI ID, FI ORG, URL as follows:

    US Bank, USBANK, 1401, www.oasis.cfree.com/test.ofxgp

    Click "I have already changed my password" if you have had the setup working before. If not (and I remember right), you get a temporary PW from US Bank, enter it and enter your new/desired OFX PW (4-8 ch and separate from your website ID). Enter your user ID (a number from US Bank, not the same as for the website), click Ok.

    Select download transactions from the Online menu and enter your ID (if not already filled in) and OFX password.

  10. 10 Posted by hmd on 14 Mar, 2019 10:23 PM

    hmd's Avatar

    I tried avp2's suggestion, entering in the specified info. When entering my customer id, i see that both Bill Payment and Online Banking check boxes are greyed out.

    I then get the MD window saying to finish. When I finish. no password is requested and the billpay service is not enabled. Attached is a selection from the console log.

    I've checked several times that I'm entering correctly the info avp2 specified. The only difference is that I prepended https:// to the URL for cfree.com.

    In case it makes a difference, I'm using Moneydance 2017.10 (1706).

    Looks like we are getting closer, but still no cigar for me. Anyone else get it working?

    thx, hf

  11. 11 Posted by avp2 on 15 Mar, 2019 04:25 AM

    avp2's Avatar

    Comm initiated by online setup is different than comm initiated by a download, or bill pay, request. The first bill pay or download request after an online setup will ask for your password. Online setup, usually just asks for your user ID or, so you can change it as needed, shows what it has from a previous setup.

    I assume you initiated an online download, but the log only shows online setup comm. If you did not do a download you should - it may work even if the online setup comm had problems as the server info looks correct in your log.

    Bill pay is a separate function from download. I believe (but may be wrong) the bill pay check box works as follows: It is set according to info from the bank’s server during online setup. It can be manually overridden if it is enabled by the bank. If online setup thinks it is not enabled by the bank, it would not be checked, would not work and not allow you to manually check it.

  12. 12 Posted by avp2 on 15 Mar, 2019 07:58 PM

    avp2's Avatar

    Looks like things not 100%. Today, transaction download working normally. Bill Pay, however throwing error message most times, but then showing payment and payee windows (most of the time) after clicking the error message Ok.

    A communication or parsing error occurred. This could be the result of a network problem, a proxy error, or misconfigured server.Error Description: java.io.IOException: HTTP Error:500 Internal Server Error

  13. 13 Posted by James Galbraith on 16 Mar, 2019 03:42 AM

    James Galbraith's Avatar

    I am also using version 2017.10 (recently updated) and having issues downloading transactions from USBank for the last couple of weeks. When I go into the Online Menu, everything is grayed out except for "Download All Accounts". How do I get this thing to let me change my online setup?

    Thanks in advance.

  14. 14 Posted by James Galbraith on 16 Mar, 2019 02:37 PM

    James Galbraith's Avatar

    My bad. I was able to get into my online set and follow avp2's instructions. But alas, continue to get the HTTP Error:400 Bad Request error.

  15. 15 Posted by avp2 on 16 Mar, 2019 03:25 PM

    avp2's Avatar

    Quit for me today too. Similar error/s as before. I guess they have made another change.

    BTW and for others, I guess you noticed you have to open an account (register) to un-grey the online setup menu functions.

  16. 16 Posted by James Galbraith on 16 Mar, 2019 04:50 PM

    James Galbraith's Avatar

    Here is some information I was able to gather. I found some other OFX information at OFXHome.com for US Bank. The URL was listed as:
    https://www.oasis.cfree.com/1401.ofxgp

    Tried this and see this in the console log. After initial changes to online setup, an error was received from moneydance.com:

    warning: unable to refresh FI info from moneydance.com. error: java.lang.Exception: Got non-OK response when querying FI info: 404
    warning: unable to refresh FI info from moneydance.com. error: java.lang.Exception: Got non-OK response when querying FI info: 404
    Sending message to https://www.oasis.cfree.com/1401.ofxgp

    When the connection request is sent to cfree.com it looks like an Internal Server Error:

    <<<<77<<<<
    connecting to: https://www.oasis.cfree.com/1401.ofxgp with method: POST
    Connecting to www.oasis.cfree.com
    acceptable protocols: TLSv1 TLSv1.1 TLSv1.2
    Connecting with https headers:
    POST /1401.ofxgp HTTP/1.1
    Content-Type: application/x-ofx
    Host: www.oasis.cfree.com
    Content-Length: 577
    Connection: close
    User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063
    Accept: /
    Date: Sat, 16 Mar 2019 10:42:01 MDT
    Accept-Language: en-us
    Cache-Control: no-cache

    ---end headers HTTP/1.1 500 Internal Server Error
    Date: Sat, 16 Mar 2019 16:42:01 GMT
    Server: Apache
    X-Frame-Options: SAMEORIGIN
    Content-Length: 883
    X-Powered-By: Servlet/2.5 JSP/2.1
    X-XSS-Protection: 1; mode=block
    X-Content-Type-Options: nosniff
    Content-Security-Policy: default-src 'self';
    Strict-Transport-Security: max-age=31536000 ; includeSubDomains
    Connection: close
    Content-Type: text/html; charset=UTF-8

    HTTP response headers:
    date: [Sat, 16 Mar 2019 16:42:01 GMT]
    server: [Apache]
    content-length: [883]
    content-security-policy: [default-src 'self';]
    x-xss-protection: [1; mode=block]
    x-content-type-options: [nosniff]
    x-frame-options: [SAMEORIGIN]
    x-powered-by: [Servlet/2.5 JSP/2.1]
    connection: [close]
    content-type: [text/html; charset=UTF-8]
    strict-transport-security: [max-age=31536000 ; includeSubDomains]
    Reading message from https://www.oasis.cfree.com/1401.ofxgp

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Draft//EN">uh oh, we've gotten some OFX with no headers: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Draft//EN">
    Error refreshing profile information:
    java.io.IOException: HTTP Error:500 Internal Server Error
    at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.sendMessage(OFXConnection.java:2745) at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.sendMessage(OFXConnection.java:2569) at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.refreshServiceInfo(OFXConnection.java:626) at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.initSecureServices(OFXConnection.java:916) at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.refreshServiceInfo(OFXConnection.java:614) at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.refreshServiceInfo(OFXConnection.java:607) at com.moneydance.apps.md.view.gui.ofxsetup.OFXSignupWizard$1.run(OFXSignupWizard.java:172) at com.moneydance.apps.md.view.gui.TaskIndicator.run(TaskIndicator.java:93) at java.lang.Thread.run(Thread.java:748)

    I hope this helps shed some light on what is going on. I need to get this fixed or will need to find an alternative.

  17. 17 Posted by avp2 on 16 Mar, 2019 11:36 PM

    avp2's Avatar

    FWIIW, MD's built-in browser access method makes the website access/download/import process a bit easier. You put the URL of your USBank logon website page in the URL spot of account setup and click “download” transactions. I am using this method until OFX gets fixed. Remember, though, that website bill pay does show OFX scheduled payments and vice versa.

  18. 18 Posted by avp2 on 17 Mar, 2019 04:39 PM

    avp2's Avatar

    I was trying some server URL variations this morning and OFX came back up after removing the ending "gp", i.e. www.oasis.cfree.com/test.ofx. Interestingly, the console log showed MD added the gp back after getting a successful FI update, which had been failing before I cut the gp.

    So, don't know what happened, but it is working now for me. If it does not come back up for you, you may also be able to get it going by using the online setup advanced function to cutoff the gp on the URL end.

  19. 19 Posted by hmd on 17 Mar, 2019 11:16 PM

    hmd's Avatar

    Still having problems w/ bill pay and transaction downloads after stripping the gp off the url when entering in the "Advanced Setup" after specifying a new connection.

    Sure would be nice if IK could give us an update on the resolution of the problem.

  20. 20 Posted by hmd on 18 Mar, 2019 12:44 AM

    hmd's Avatar

    OK, I found a program that will successfully download from US Bank. Don't know about bill pay since the program doesn't support that. You can get a verbose description of what is being transferred by using the verbose flag.

    For those comfortable w/ a terminal and python, use the latest version of the program at <http://captin411.github.io/ofxclient/index.html>. I did:

        pip install git+https://github.com/captin411/ofxclient.git@master
        ofxclient -v

    For the bank, enter w/out quotes" US Bank", and the pick it from the list.
    (It gets the data from <http://www.ofxhome.com/>).

    Then enter in your id and password. I then successfully requested a file of recent transactions. The verbose output specified the data sent back and forth.

    Maybe this help someone figure out what is causing MD to hiccup on what US Bank is doing now.

  21. 21 Posted by Jonathan on 19 Mar, 2019 05:28 PM

    Jonathan's Avatar

    Just getting my name on this since I'm experiencing the same issue.

  22. 22 Posted by mjw on 19 Mar, 2019 10:51 PM

    mjw's Avatar

    Henry,
    How about a status report for this issue? It's been over a week since I first reported it in a private thread.

  23. 23 Posted by Jim Soper on 20 Mar, 2019 03:37 PM

    Jim Soper's Avatar

    I'm having the same problem.

  24. 24 Posted by avp2 on 21 Mar, 2019 11:57 PM

    avp2's Avatar

    Today, downloads still working, but bill pay flaky, especially payee updates. Will have to do website bill pay as can not trust the OFX bill pay function.

  25. Support Staff 25 Posted by Henry on 22 Mar, 2019 08:12 AM

    Henry's Avatar

    Hi All,

    Unfortunately we're still working to get this connection problem resolved. We're already implemented a few changes to Moneydance and the connection information, but I'm afraid this hasn't fixed the issues. We're continuing to work on this, and our lead developer is on the case.

    Another US Bank customer has reported that he spoke with the bank on March 20 and the bank rep advised the problem is at their end. The customer was assured that the bank would soon announce improvements to their online banking program and that the Moneydance problem would be corrected.
    We're trying to speak with a member of the US Bank team so we can ensure this is correct.

    If you need to update your accounts before this is resolved, you can download files from your banks website. You should use the OFX or the QFX file format, then import these file to Moneydance using File --> Import.
    The import instructions are also available here.

    Henry
    Infinite Kind Support

  26. 26 Posted by shawn.henderson... on 22 Mar, 2019 12:22 PM

    shawn.henderson.usa's Avatar

    I'm still having this same problem going on three weeks.

  27. 27 Posted by avp2 on 22 Mar, 2019 07:04 PM

    avp2's Avatar

    Did a little more testing. Bill pay works for me, but only for existing payees. I can not edit, or delete, an existing pay and can not add a new payee. Console does not show any unusual messages. Do get some unrelated error messages from their server, like "can not update payment because it has been canceled" and "address field too long" (when trying to edit by moving address line 1 contents to address line 2, leaving 1 blank).

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac