2019 won't let me choose Sync Method

~Dan N's Avatar

~Dan N

05 Feb, 2019 11:58 AM

I updated to 2019 and noticed I can't sync with my phone anymore. I looked at the settings and MD Sync Settings are set as "Sync Method: Don't Sync" and I can't change it.

Did I miss something or is this a bug?
Thanks for the feedback,
Dan N

  1. 1 Posted by derekkent23 on 05 Feb, 2019 03:08 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    The fact that under FILE -SYNCING the SYNCING METHOD is set to DON’T SYNC and greyed out and can’t be changed indicates that you are or were syncing with another computer.
    When two computers sync one is the primary and one is the secondary. The primary is the computer other devices like phones sync to and its syncing method can be changed. The sync method on a secondary computer can’t be changed from don’t sync.
    If you no longer sync to another computer and need to convert your secondary data set to a primary data set post and I can provide instruction.

    Hope this helps

  2. 2 Posted by ~Dan N on 05 Feb, 2019 03:41 PM

    ~Dan N's Avatar

    Hi Derek,
    I currently use MD on one computer at the moment but did *try* to set it up
    on another in the past. The one I'm on now is my main computer (home
    desktop) and the one I would like to use as my Primary one. I would
    appreciate any advice you have to setting it up that way and any insight
    you have about keeping it this way if I want to set up MD on a second
    laptop...which I would like to do if time allows before I leave for a work
    trip next week.

    Thanks for your help,
    Dan N

  3. 3 Posted by derekkent23 on 05 Feb, 2019 04:21 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    Do a FILE – EXPORT BACKUP in case something goes wrong.

    In your phone setting disconnect from sync. Note any transaction in your phone but not in your computer will be lost. So, if necessary, update your computer first.

    In Dropbox delete the folder “.moneydancesync”

    To convert a secondary data set to a primary data set you need to run the attached script md2017_convert_secondary_to_master.py in Moneydance 2019. Don’t worry it states 2017.

    With your data set open click WINDOW - SHOW MONEYBOT CONSOLE use OPEN SCRIPT to select the script and click RUN. Close and reopen Moneydance.
    You should now find you can change the sync method under FILE – SYNCING.

    To start syncing see http://help.infinitekind.com/kb/syncing-and-sharing-data
    I recommend using the Sync Method Dropbox Folder.

    Hope this helps.

  4. 4 Posted by ~Dan N on 05 Feb, 2019 05:06 PM

    ~Dan N's Avatar

    Thanks Derek!
    That gave me back the option to select a sync method.
    Now I'll set up the phone again once it finishes the dropbox sync.

    Dan N

  5. 5 Posted by derekkent23 on 05 Feb, 2019 05:19 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    Glad I was able to help.

    Have Fun.

  6. 6 Posted by mcarpenter4 on 06 Feb, 2019 04:25 PM

    mcarpenter4's Avatar

    This comment was split into a new private discussion: 2019 won't let me choose Sync Method

    Hi derellemt23
    My boss and I use this program to monitor the department budget. He originally set it up in Dropbox from his computer and we had successful syncing for a few years. However, I got a new laptop for work last Sept and since then we cannot seem to figure out how to get back our syncing. Here is what I would like to do at this point. The current program is on my computer, he does not have any of the updated information as the syncing has not been on. I have backed up the file to a "shared folder." However, we used Dropbox as our sharing option last time, which I think is way more confusing. I understand that we need to have his computer change the syncing preference from Dropbox to Shared Folder. Here are my questions:

    1. Can he change the syncing preferences to "shared folder" without having the most recent program on his computer?

    2. Can I go in after he does this and share the current updated program with him instead of him sharing with me? If not, and since he is the primary computer, how can he get my updated program on his system from our backed up file, so he can "re-share" it with me using our new method of "Shared Folder" instead of "Dropbox"?

  7. 7 Posted by derekkent23 on 07 Feb, 2019 08:23 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    I am assuming you are running either Moneydance 2017 or 2019?
    What version and build of Moneydance are you running. e.g. 2019.1(1855).
    It important that both computers are running the same version and build.
    What are your computers operating system.
    As your computer is the one that's up to date it needs to be the primary computer.
    If you look under FILE - SYNCING can you change the syncing method or is it grayed out. If its greyed out the first step would be to convert the data set from a secondary to a primary data set. I can provide instructions.
    I would recommend once you have got your data set sorted out you reset syncing and use the syncing method Dropbox folder. Again I can provide instructions.

    Provide the information I have requested and I will post the next step.

  8. 8 Posted by Anna on 08 Feb, 2019 01:49 PM

    Anna's Avatar

    Derek! You ROCK!!!!!!!!

    That worked!

    First time I've ever run a Python script, too. THANKS!!!!

  9. 9 Posted by derekkent23 on 08 Feb, 2019 03:00 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    Glad I was able to help.

    Have Fun.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac