Updating prices

pdd222's Avatar


05 Dec, 2017 08:58 PM

Until there is a new way to download prices, I have tried to import prices from a file. However, as soon as I click on the "import" button, Moneydance quits. It does not even get as far as the "choose file" screen. I have tried a half dozen times and the program does the same thing every time. Is there a bug here?

  1. 1 Posted by -Kevin N. on 05 Dec, 2017 09:48 PM

    -Kevin N.'s Avatar

    Hi pdd222,

    What version and build of Moneydance are you using and what OS are you using?

    Per the change log:
    build 1643 - work around macOS High Sierra bug that caused a crash when certain file chooser windows are invoked

    -Kevin N. (not a member of MD support)

  2. 2 Posted by pdd222 on 06 Dec, 2017 04:52 PM

    pdd222's Avatar

    Hi Kevin,

    Im using Moneydance 2017.3 (1622) and High Sierra 10.13.1. So maybe the bug is in the OS and not Moneydance? Thanks for your reply.


  3. 3 Posted by -Kevin N. on 06 Dec, 2017 04:56 PM

    -Kevin N.'s Avatar

    Hi Paul,

    Provided that you did NOT purchase Moneydance through the Apple store or Amazon, then you can d/l the preview build of Moneydance (currently MD 2017.6 (1653) here:


    -Kevin N.

  4. 4 Posted by pdd222 on 08 Dec, 2017 10:23 PM

    pdd222's Avatar

    Thank you Kevin. The preview build does resolve that problem. Now, if only someone will find a way to get automatic security price updating back or some other way to workaround the loss of data capability from Yahoo!

  5. 5 Posted by -Kevin N. on 08 Dec, 2017 10:32 PM

    -Kevin N.'s Avatar

    Hi Paul,

    Try installing the new v.1008 build of the Quotes & Exchange Rates updater.

    It requires a free, API key from Alphavantage. You'll be prompted for it when you go to use the extension.

    It's download speed is slower than before but it looks to be working for most people.

    There are some other workarounds, if you're interested, let me know and I'll dig up the links to them.

    -Kevin N.

  6. Support Staff 6 Posted by Tom Freeman on 08 Dec, 2017 10:41 PM

    Tom Freeman's Avatar

    If you are on the most current build of MD 2017, 1655, you can try the Quotes and exchange extesnion (version 1009). It is now set up to retrieve quotes from Alpha Advantage.

    You will have to gt an API key from Alpha Advantage. There is a button on the extension to facilitate that..

    The issue for the price import may be that the file is not set up in a format that Moneydance can read. How are you generated the file you are attempting to import?

    Tom Freeman
    Infinite Kind Support

  7. 7 Posted by pdd222 on 09 Dec, 2017 12:24 AM

    pdd222's Avatar

    After several attempts, version 1009 & AlphaAdvantage is now updating the prices for me. Thanks!

  8. Support Staff 8 Posted by Tom Freeman on 09 Dec, 2017 12:31 AM

    Tom Freeman's Avatar

    Glad to hear the prices are updating. Any feedback about how the extension is working with Alpha Advantage will help us improve the service.

    Tom Freeman
    Infinite Kind Support

  9. 9 Posted by gandrews82 on 09 Dec, 2017 04:54 PM

    gandrews82's Avatar

    The new extension (V1009) running with the preview version (2017.6 - 1655) was working fine - until i updated for last night’s closing prices. Almost all (but not all) of my UK listed share portfolio ended up being priced as if they were GBP Pounds and not GBP Pence, so these are all showing at 100th of their value. There is the option of using either, but they were all working fine this past week using London Stock Exchange (Pence), except for two for which the feed is in Pounds. Now its a dogs breakfast.

    Likely to be some kind of issue between intra-day and end of day files ?

  10. 10 Posted by derekkent23 on 10 Dec, 2017 10:52 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    Just read someone else having the same problem, post 144 in this thread http://help.infinitekind.com/discussions/investments/2499-error-999...

    As a side issue as it looks like you are a UK investor is Alpha Vantage supporting all your Securities. I am finding poor support for my UK\Ireland\Europe domiciled Funds. I am experimenting with a third-party program that allows me to import into Moneydance and out of 42 funds it finds 37.

  11. 11 Posted by gandrews82 on 10 Dec, 2017 06:13 PM

    gandrews82's Avatar

    thanks. I seem to remember that this issue (that of some price feeds on UK stocks varying between pence and pounds depending on the time of day) was prevalent in an excel tool I used to use before I converted over to Moneydance.

    Frustrating thing is the new moneydance extension was working fine for more than a week, and all 37 of my stocks were returning correct prices each time i ran it. i think it does have something to do with end of day vs. intraday pricing conventions being different.

    The security price loader extension provided by Mike Bray works, but it requires manual manipulation which is a bit of a faff.


  12. Support Staff 12 Posted by Tom Freeman on 15 Dec, 2017 03:21 PM

    Tom Freeman's Avatar

    There is an option in the exchange filed for London exchange pence and London exchange GBP. If choosing the correct one of these and the quote is still downloading incorrectly, you can double-click on the exchange field in the extension and an edit window pops-up. One of the options is to add a multiplier. You can use this to automatically adjust the downloaded price.

    Tom Freeman
    Infinite Kind Support

  13. 13 Posted by ssvatora on 15 Dec, 2017 07:09 PM

    ssvatora's Avatar

    Let me know if I should start a separate discussion, but I am unable to download historical prices with MD v2017.4 (1624) with Q&ER v1012. I'm getting a "No trusted certificate found" on all my securities.
    An example console message:

    getting history using url: https://www.alphavantage.co/query?function=TIME_SERIES_DAILY&symbol=XLF&apikey=BOHJNWQ1M0E8YYSZ&datatype=csv
    TRUSTMGR: checking cert chain: CN=www.alphavantage.co
    Saving certificate: 0
        subject: CN=www.alphavantage.co
         issuer: CN=Let's Encrypt Authority X3, O=Let's Encrypt, C=US
      not after: Tue Jan 16 16:12:01 MST 2018
     not before: Wed Oct 18 16:12:01 MST 2017
       filename: unknown_cert_0.der
    Saving file to C:\Program Files\Moneydance\unknown_cert_0.der
    Error writing unknown cert to file: java.io.FileNotFoundException: unknown_cert_0.der (Access is denied)
    Saving certificate: 1
        subject: CN=Let's Encrypt Authority X3, O=Let's Encrypt, C=US
         issuer: CN=DST Root CA X3, O=Digital Signature Trust Co.
      not after: Wed Mar 17 09:40:46 MST 2021
     not before: Thu Mar 17 09:40:46 MST 2016
       filename: unknown_cert_1.der
    Saving file to C:\Program Files\Moneydance\unknown_cert_1.der
    Error writing unknown cert to file: java.io.FileNotFoundException: unknown_cert_1.der (Access is denied)
    !! Warning: encountered untrusted cert (saving) !!
    No current price found for Financial Select Sector SPDR� ETF (XLF)

    The "Error writing unknown cert to file" issue appears to be due to Windows 10 and UAC, but even running 'As Administrator', I am able to write the cert file with no error, but still no download of price data.
    I was also able to manually visit the URL (listed above), save the resulting csv file, and then manually import the data into MD, so the process of using Alpha Avantage appears to be working (I did get and set my free API key). There just appears to be an issue of Q&ER either getting the resulting csv file from the URL and/or reading the resulting csv file and importing the data into MD.

  14. 14 Posted by ssvatora on 15 Dec, 2017 07:27 PM

    ssvatora's Avatar

    Oh, and as another piece of information, the manually downloaded csv file has the date column labeled as "timestamp", and it needs to be changed to "date" for the import to be successful.

  15. 15 Posted by derekkent23 on 16 Dec, 2017 10:01 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    The certificate is included in the latest released build of 2017 at https://infinitekind.com/download-moneydance-personal-finance-software

    Hope this helps.

  16. 16 Posted by gandrews82 on 16 Dec, 2017 11:18 AM

    gandrews82's Avatar


    Thanks. I found it - different access on MAC. will give that a go next time I spot an anomaly.


  17. 17 Posted by ssvatora on 16 Dec, 2017 05:01 PM

    ssvatora's Avatar

    OK, thanks for the clue derekkent23! I saw that the latest download is 2017.6 (1656), which is newer than what I was using, so I downloaded and updated. Now Q&ER is downloading data for me. And it looks like the certificate errors are gone as well.

  18. 18 Posted by pnewman3 on 27 Dec, 2017 04:40 PM

    pnewman3's Avatar

    UK share prices do not seem to download correctly. Just a bunch of random numbers. I have played around but no success. anyone know if this AlphaVantage fix works for UK shares or only USA shares?

  19. 19 Posted by -Kevin N. on 27 Dec, 2017 05:52 PM

    -Kevin N.'s Avatar

    Hi pnewman3,

    I replied to your other post.

    -Kevin N.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac