Please Note: We've moved Moneydance and SyncSpace's support to a new location. Please join us for support and discussion at infinitekind.zendesk.com.

Two finger scroll Linux opens tons of windows when viewing reports

jw.hendy's Avatar

jw.hendy

25 Aug, 2011 04:26 AM

When viewing Detailed Income vs. Expense, if I two finger scroll, a massive amount of windows open up. It's as if I double clicked every transaction I pass over and they all open to their respective accounts. In account views, I've noticed that two fingers on the trackpad seem to highlight the account rather than queue things up for scrolling.

  • Moneydance 2011 (791)

  • $ uname -a: Linux Macrophage 3.0-ARCH #1 SMP PREEMPT Wed Aug 17 21:55:57 CEST 2011 x86_64 Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz GenuineIntel GNU/Linux

  • $ cat /etc/X11/xorg.conf.d/10-synaptics.conf Section "InputClass"

      Identifier "touchpad catchall"
      Driver "synaptics"
      MatchIsTouchpad "on"
      MatchDevicePath "/dev/input/event*"
      Option "TapButton1" "1"
      Option "TapButton2" "2"
      Option "TapButton3" "3"            
      Option "VertEdgeScroll" "off"
      Option "VertTwoFingerScroll" "on"
      Option "HorizEdgeScroll" "off"
      Option "HorizTwoFingerScroll" "on"
    

    EndSection

Any other helpful details?

  1. Support Staff 2 Posted by Ben Spencer on 26 Aug, 2011 03:25 AM

    Ben Spencer's Avatar

    Hi

    I am not able to reproduce the problem on Ubuntu 11.04. Are you using the OpenJDK by any chance? If you are could you try installing the JVM from Oracle instead and let me know if that makes a difference.

    Ben Spencer
    Moneydance Support

  2. 3 Posted by jw.hendy on 26 Aug, 2011 03:43 AM

    jw.hendy's Avatar

    Hmmm. Not sure, then.


    $ sudo pacman -Qi jdk Name : jdk
    Version : 7-3
    URL : http://jdk7.java.net/
    ...

    Description : Oracle's Java Development Kit

    Any other suggestions?

    It's a Macbook; would that make a difference?

  3. Support Staff 4 Posted by Ben Spencer on 26 Aug, 2011 03:58 AM

    Ben Spencer's Avatar

    Could you run Moneydance and select Help->Console Window... Then copy and paste the output to this discussion.

    Could you run

    java -version

    from the terminal and paste output to this discussion.

    I can't think of a reason why the mac book track pad would cause a problem and I admit I haven't tried MD on Linux on a mac. Are you running Linux in a VM on the mac or is it natively installed?

    Ben Spencer

  4. 5 Posted by jw.hendy on 26 Aug, 2011 04:07 AM

    jw.hendy's Avatar

    I dual boot with OS X with Linux natively installed. Yes, not sure why the Macbook trackpad would be different... just brainstorming :) I wonder if I need to play with my Linux synaptics settings.

    Here you are:

    Starting Moneydance 2011 (791)
    Settings Folder: /home/jwhendy/.moneydance
    OS: Linux 3.0-ARCH amd64
    Java: 1.7.0 (Oracle Corporation)
    
  5. Support Staff 6 Posted by Ben Spencer on 26 Aug, 2011 08:02 AM

    Ben Spencer's Avatar

    If the two finger scrolling is working in other applications then I imagine your synaptics settings are fine.

    Are you able to two finger scroll in something like nautilus?

    Are you able to two finger scroll in other parts of Moneydance?

    I don't have java 1.7 installed and since it is relatively new (been out less than a month) I could imagine there is a bug in 1.7 with two finger scrolling. Could you try rolling back to an earlier version of Java? I am running 1.6_22 without problems.

    Ben Spencer

  6. 7 Posted by jw.hendy on 26 Aug, 2011 01:37 PM

    jw.hendy's Avatar

    Hi Ben,

    I'm able to two finger scroll everywhere in Linux. I just downgraded to jdk6/jre6 and experience the same behavior. What I did notice, though is that in account view, when I got to two finger scroll, the right click menu pops up immediately. I can kind of scroll around still, but as soon as I stop, the right click menu shows up on the last transaction under my cursor when my two fingers left the trackpad.

    So two fingers, even rested lightly on the trackpad, is getting interpreted as a right click. I wonder if that's on my end with synaptics settings? I have three finger tap set up as right click and if I rest three fingers on the trackpad elsewhere, nothing happens. I have to tap with some force.

    Hope this helps narrow things a little bit. I can play with synaptics settings tonight to see if I can make any progress..

    Thanks for the persistence!
    John

  7. 8 Posted by jw.hendy on 26 Aug, 2011 03:15 PM

    jw.hendy's Avatar

    So out of curiosity, it occurred to me that I could install Moneydance on my work computer which also runs Arch Linux. I have about the same setups on both computers (Openbox, Arch, synaptics, x86_64, etc.) so I thought that might be interesting.

    On my HP8540w, I do not get this issue, despite having the same 10-synaptics.conf settings:

    $ cat /etc/X11/xorg.conf.d/10-synaptics.conf
    Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
    Option "VertTwoFingerScroll" "on"
    Option "HorizTwoFingerScroll" "on"
    EndSection
    

    So maybe it is something on the Macbook after all?

  8. Support Staff 9 Posted by Jessica Little on 26 Aug, 2011 03:19 PM

    Jessica Little's Avatar

    Hi John,

    It wouldn't surprise me at all if there is something about the MacBook hardware that doesn't play well with Linux. Could you try two-finger scrolling in another Java application on Linux? jEdit is a good choice for this. If the problem exists in jEdit as well as Moneydance, but none of your other applications, then it may be a Java problem also.

    Jessica Little
    Moneydance Support

  9. 10 Posted by jw.hendy on 26 Aug, 2011 03:27 PM

    jw.hendy's Avatar

    Thanks Jessica. I can try that tonight. In my terminal window, I do get a lot of these:

    MEvent. CASE!
    

    Not sure if that means anything to you.

    I'll report back about jEdit tonight. Thanks for the assistance. Your speed/support has been top notch.

  10. Support Staff 11 Posted by Jessica Little on 26 Aug, 2011 03:52 PM

    Jessica Little's Avatar

    No problem. And, just so you know, that message is more informational than error and doesn't mean anything in this particular case.

    Jessica Little
    Moneydance Support

  11. 12 Posted by jw.hendy on 27 Aug, 2011 01:35 AM

    jw.hendy's Avatar

    Jessica -- I just tried jEdit and the behavior is the same as Moneydance. I can scroll, but simply resting two fingers on the trackpad registers as a click or activity of some sort. This should not be the case. I'll fiddle with things and see what I find.

  12. Support Staff 13 Posted by Jessica Little on 27 Aug, 2011 01:39 PM

    Jessica Little's Avatar

    Hi John,

    Definitely sounds like either a synaptics problem or a Java bug. If you do find a solution, I'd be interested in hearing it. Or if you discover that it really is a bug in Moneydance, definitely let us know.

    Jessica Little
    Moneydance Support

  13. 14 Posted by jw.hendy on 28 Aug, 2011 03:33 PM

    jw.hendy's Avatar

    Jessica -- will do. I've started a post about it on the Arch Linux forums as well (https://bbs.archlinux.org/viewtopic.php?id=125334) as on SuperUser (http://superuser.com/questions/328616/two-finger-scroll-registering...).

    John

  14. 15 Posted by jw.hendy on 22 Dec, 2011 03:07 AM

    jw.hendy's Avatar

    Yay! Fixed. Thanks to the Superuser post above, I got a response that the issue comes down to synaptics X11 options. For me, these are located in /etc/X11/xorg.conf.d/10-synaptics.conf. The key options are:

    Section "InputClass"  
        ## whatever options you have ##  
        Option "HorizEdgeScroll" "off"  
        Option "HorizTwoFingerScroll" "off"  
    EndSection
    

    So, problem solved. I checked jedit as well and it registers two finger vertical scrolling as a click event with HoizTwoFingerScroll set to "on," and stops that behavior (as does MDance) with the option off as shown above. Not a killer for me, as I don't ust horizontal scrolling much anyway. I was just happy to find the resolution

    As a side note, the poster in Superuser mentioned that it's independent of distro and computer. The user has the same problem as my Macbook running Arch x86_64 on a Dell running OpenSuse.

    Thanks again for working with me on a solution previously.

  15. Support Staff 16 Posted by Jessica Little on 22 Dec, 2011 01:09 PM

    Jessica Little's Avatar

    Hi John,

    Thanks for the update. I'm glad the folks on SuperUser were able to help figure out what is going on.

    Please let me know if I can be of further assistance, and thanks for using Moneydance!

    Jessica Little
    Moneydance Support

  16. Jessica Little closed this discussion on 22 Dec, 2011 01:09 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac